This question already has an answer here:

My machine only has Ubuntu installed (13.04) but one data drive is NTFS (because I didn't realize that the disk was NTFS formatted when I started using it). I now used Gparted to reduce the partition and make room for a new data partition in ext4 format so that I can move the data there instead, then delete the NTFS partition and resize the ext4 partition to use the entire disk.

After reducing the NTFS partition and creating the ext4 partition, Gparted now Gparted has an exclamation mark (top) and tells me this (bottom).

I'm asked to run Windows Checkdisk twice, but I don't have Windows installed and it's very tedious to pull the drive out of the computer and hunt down a Windows pc with SATA connectors. Is there any way for me to fix this, besides using Windows?

The NTFS data partition is not available until I've fixed it, so I can't read its data and copy it to the new ext4 partition. If I could just reliably read it, this problem might be irrelevant.

enter image description here enter image description here

Final update and solution:

I can't accept either answer because the Linux tools could not resolve the problem. In the end, I booted my machine with a Windows 7 installation disk and started the repair/recovery function. In there, I could open a command prompt and run the chkdsk /f which solved the problem :-)

marked as duplicate by NickTux, Eric Carvalho, Thomas Ward, Eliah Kagan, Seth Aug 10 '13 at 2:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You do not need to install ntfsprogs, it is now part of the default ntfs-3g driver. And with some older versions of Ubuntu installing ntfsprogs installed the old version and uninstalled ntfs-3g.

On April 12, 2011 it was announced that Ntfsprogs project was merged with NTFS-3G http://en.wikipedia.org/wiki/Ntfsprogs

man ntfsprogs (from 12.04,so applies to newer versions also) The ntfsprogs are part of the ntfs-3g package which can be downloaded from: http://www.tuxera.com/community/

From synaptic: ntfsprogs Package to ease upgrading from older ntfsprogs packages to the new ntfs-3g package. This package can be purged at anytime once the ntfs-3g package has been installed.

The ntfsfix does minor repairs which may work but sets the chkdsk flag so if you reboot it runs it. And partitions with the chkdsk flag are usually not mounted with ntfs-3g to prevent further damage that chkdsk might not fix. But if not a bootable Windows then chkdsk will not be run. You need either a Windows repairCD or some of the third party tools may run chkdsk.

Third party chkdsk tools Also has chkdsk and some other Windows repairs in free version: http://www.partitionwizard.com/features.html May be able to run chkdsk from Hiren's boot CD. (mini xp.) Hiren's Boot CD, and do a chkdsk on the XP

EASEUS Partition Master http://www.partition-tool.com/personal.htm

Partition Wizard




Note: Whenever you're dealing with partition, make sure that you have a complete backup just to be on the safe side.

Try this. You can use a program called ntfsprogs. If its not installed, you can install it by, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install ntfsprogs

Once installed, you need to find out you NTFS drive name, just do sudo fdisk -l, to find that out, once you know the name, then

sudo ntfsfix /dev/sdXX

Make sure that you replace the XX with your drive's name.

Note: Whenever you're dealing with partition, make sure that you have a complete backup just to be on the safe side.

Not the answer you're looking for? Browse other questions tagged or ask your own question.