I am unable to print documents using my HP printer. However, I am able to print test pages.

What I tried:

I have tried removing and re-installing the printer from the system settings but I can only print once (the first task). Then all the following tasks get stuck at the "Rendering Completed" status.

I additionally tried restarting the computer which leads in the same task mentioned above.

Moreover, I logged into the CUPS system ( 1.6.2) from http://localhost:631

From there, I removed the printer, restarted it and re-installed with no sucess.

System Specifications:

System : Ubuntu GNOME 13.04

Memory: 3.9 GB

CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ × 2

OS-type : 32 bit

Graphics: Gallium 0.4 on NVA3

Printer: HP Deskjet 2050 j510 Series

IP Adress: localhost

I had no problems with my previous OS which was Pinguy OS 11.04 ( a distro based on Ubuntu 11.04) and it's the first time I use my printer at this OS.


Printer stuck at Rendering Completed status My printer stuck at "Rendering Completed" status.

enter image description here From the CUPS web interface; you can see that "Rendering Completed" is stuck at the state of the print process.

**EDIT:**I tried printing from the pdf.js pdf viewer of firefox: I wait for about 5 minutes for a 10 pages document to print, the document is printed like faded and sort of in bold font (I accuse rendering for that). Then the status of the printer gets stuck at 'Rendering Completed' but I can print later on. Again, for the next prints I wait for 5 minutes minimum ( I wait for the 'Rendering....' bar to fill ) and the printing is weird.

  • How is the printer connected to your computer? USB? Network? – guntbert Aug 16 '13 at 23:01
  • My printer is connected through USB. – dlin Aug 17 '13 at 0:36

This happened once when I launched the print job before the printer was powered on.

Using Maintenance > Resume printer from the cups Printers page did launch the print job successfully.

  • This solved my problem. But I also had to downgrade hplib to 3.15.6 – shaunakde Aug 19 '15 at 9:58

Uninstalling and re-installing the hplip package was enough to bring the printer back to normal use.

  • 1
    I had the very same problem with an USB HP Laserjet P1005 and Ubuntu 13.10. Re-installing hplip did not do the trick for me. However, it worked after deleting hplip altogether and re-installing the printer via the GUI. – Michael Osl Oct 27 '13 at 21:14
  • After upgrading to cups-1.7.5, I also had to remove the printer from the web UI and re-add. Started working immediately. – lkraav Dec 22 '14 at 22:16

I had the same problem in Ubuntu 14.04, HP Printer. I fixed it by searching for Printers (which is an app shows list of available printers) via Unity Search. Then after selecting my printer from the list and (right click and )enabling it.

Sometime i had this issue solved by removing the printer which stuck from there and add it again.

  • 2
    This doesn't explain how you searched for Printers. Nor does it have anything to do with his issue. – Virusboy Dec 4 '14 at 5:33
  • 1
    Oh, i missed it. I actually searched through unity search bar for Printers. It's in the application list. Then i proceeded as said above. Sorry i missed it. – Ajeeb.K.P Dec 5 '14 at 14:04

I had the same issue in Rebecca after trying to print an image. I was lucky I guess. I selected Administration/Printers. Right-clicked on my printer icon and selected "Enabled" and it started printing.


I had a same issue. It causing from the filter in /usr/lib/cups/filter/[which filter does ppd file bring] which is calling from .ppd file that you use that non-arm executable file (mine was Intel80686). So i installed CITIZEN ST2000 thermal printer ARM driver. Now it is working clearly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.