I have a HP sleekbook envy with a broadcom 4313gn wifi adapter, and i can't get the wireless adapter to work. I can see wireless connections that are available, but when i try to connect and put in the WEP key it tries to connect for around 1 minute and then asks me for the WEP key again, over and over again.

I have only gotten a wired connection to work with Ubuntu, but I know my wifi adapter is fine because i'm dual booting windows 7 with Ubuntu 12.04, and although the wifi reception isn't great i know it isn't a hardware problem (since it works with windows 7)

I have read several questions similar to this one (i tried to figure this out on my own first), but none of them had a clear solution. I thought i would just need to download a driver...

Also, i wouldn't be against upgrading my wifi adapter to one that Ubuntu supports, this one doesn't seem very good. But i'd rather get this one working if possible.

edit: these are the results from the terminal commands:

lspci -nn | grep 0280:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

lsmod | grep -e wl -e brcmsmac:

wl                   3074895  0 
cfg80211              205774  1 wl
lib80211               14381  2 lib80211_crypt_tkip,wl

edit 2: I'm not sure if i ran it correctly...

ryan@ubuntu:~$ sudo su [sudo] password for ryan: Sorry, try again. [sudo] password for ryan: root@ubuntu:/home/ryan# sudo su root@ubuntu:/home/ryan# apt-get remove --purge bcmwl-kernel-source Reading package lists... Done Building dependency tree
Reading state information... Done Package bcmwl-kernel-source is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. root@ubuntu:/home/ryan# echo brcmsmac >> /etc/modules root@ubuntu:/home/ryan# exit

it still doesn't work

  • Please edit your question to add the results of these two terminal commands: lspci -nn | grep 0280 and also: lsmod | grep -e wl -e brcmsmac – chili555 Aug 9 '13 at 12:28

I believe the Broadcom STA driver is incorrect for your device 14e4:4727. Please open a terminal and do:

sudo su
apt-get remove --purge bcmwl-kernel-source
echo brcmsmac >> /etc/modules

Reboot and your wireless should be operating correctly.

  • unfortunately that didn't work, i'll edit my original question to show what happened in terminal because i can't post it in a comment. – magnumtrooper Aug 11 '13 at 4:35
  • Let's also see: lsmod | grep brcmsmac and also: rfkill list all and also: iwconfig. It may be easier to paste the results here and give us the link in your reply. paste.ubuntu.com – chili555 Aug 11 '13 at 12:59
  • these are the results from those commands,i put them on ubuntu pastebin like you suggested. Also, thank you for your help, it seems like ubuntu has a tough learning curve when you start out paste.ubuntu.com/5975098 – magnumtrooper Aug 11 '13 at 21:48
  • That looks very fine! Let's dig deeper: sudo iwlist wlan0 scan and also: nm-tool and also: dmesg | grep wlan0 Use paste.ubuntu.com again, please. – chili555 Aug 11 '13 at 23:05
  • this is what i got this time paste.ubuntu.com/5976073 – magnumtrooper Aug 12 '13 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.