1

i installed mono develop with his all Packages . when i tried to create anew solution , an error message appeared to me. what should i do? this is the text which bothered me:

Error while trying to load the project '/home/theghost/Desktop/3333/3333/3333.vbproj': Project does not support framework '.NETFramework,Version=v4.0'
  • Please indicate information about versions that you use – Paulius Šukys Aug 12 '13 at 12:17
1

What version of ubuntu are you on?

Ubuntu tries to limit itself to one version of each library on the system. This means only one version of mono is available on ubuntu. The version of ubuntu you have, will determine what version of .net is supported.

For example on ubuntu 12.04, only .net 4.0 applications will run, .net 2.0 applications will not run / compile by default.

You should also be aware that vb.net is not well supported in mono. c# is really the language of choice for mono. The mono runtime itself will run vb.net applications quite well but the compiler may not work. If you want to run a vb.net application on ubuntu you really need to build it on windows and then run it on Ubuntu.

| improve this answer | |
-2

Check your config file for any attribute that tells the framework to be 4.0. Try using a lower framework. Mono Develop is not good enough in linux.

| improve this answer | |
  • how can i do that and if Mono Develop is not good enough in linux,what is the good? i`m a v.b programmer and really need to work mono – user182545 Aug 9 '13 at 12:01
  • .. and I am a bash shell programmer and really need to work on Visual Studio . :) Ever heard of CLR and CLI? Knowing that .NET framework is not directly and fully compatible with, Who has downvoted me unnecessarily? Try Wine and write code in Windows environment. – Subhadeep Aug 15 '13 at 4:44
  • I guessing you got down voted because .net 4.0 is supported on all modern versions of ubuntu, where as .net 2.0 is not (.net 2.0 programs can be run by editing there config files so they run against 4.0) so your answer is the wrong way around. I'm also guessing that you may have also been down voted for saying Mono Develop is not good enough in linux. Mono Develop is actually really good on linux, and does support .net 4.0. I use Mono Develop to develop my opensource application Wide Margin which is included in the ubuntu software center. – trampster Sep 13 '13 at 5:19
  • Well, Mono Develop is really good perhaps, and I guess I wrote "not good enough" which means the IDE is good but not much efficient if you can't write ASP.NET pages without VS or DreamWeaver. – Subhadeep Nov 27 '13 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.