First of all: this is not a duplicate of the all the "GRUB on the wrong hd" questions.


When booting, the system will not boot unless the installer USB flash drive is present. If I boot without the USB drive, the screen goes black AFTER GRUB lists the different configurations available - so GRUB is on the correct disk, its what it does next that seems to be the problem.

With the USB drive inserted, its access light starts flashing while the system boots in a normal manner.

And yes: I have tried booting from the USB drive directly and then I get the "live" version, so I have not installed the OS on the flash drive by mistake :)

I have tried sudo grub-install /dev/sda and sudo update-grub just for fun, but nothing changed.

System in short:

Ubuntu 12.04 64-bit. i3 processor. UEFI bios. 128Gb SSD drive. The SSD has a 47 Mb EFI partition and the rest mounted as '/' (XFS).

marked as duplicate by karel, Eric Carvalho, David Foerster, Zanna, mikewhatever Jan 26 '18 at 5:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Found another 'fun' thing that gives the similar symptoms; (I guess) the initial splash screen is black and if there is a disk drive missing in your system, the boot stops and asks you what to do... problem is that the black splash screen won't let you see the question, so what you see is a stuck system and no picture. Next time, I'll try pressing 's' for skip just to see what happens... – Daniel Aug 11 '13 at 15:29

The possible cause for this could be the order disks are loaded or seen by GRUB.

For example, if your USB flash drive is 'seen' before your Hard disk, your computer and Ubuntu will work OK, but, when you remove the USB drive, GRUB then thinks that the HDD is the USB flash drive, and looks for the Hard Disk which is obviously not there.

To cure this, you will have to download and run GRUB Repair, which will fix GRUB so that it work properly

  • Definitely an 'order' issue: I added a hard-drive and then the system booted without the USB flash drive... problem seems solved, but my opinion of GRUB is not so high anymore. It was for precise these reasons UUID:s were introduced, I hope that GRUB can start using them as well :/ – Daniel Aug 8 '13 at 11:38
  • If the answer helped, can you up-vote it and may be even suggest that this is the correct answer with a green tick :) Glad to have helped. – SimplySimon Aug 8 '13 at 11:41
  • Don't have the required reputation to up-vote, but I green-ticked it. Cheers! – Daniel Aug 8 '13 at 12:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.