I'm trying to install Ubuntu on an E-series Vaio with windows 8 pre-installed.

To do so, first I shrinked windows 8 partition (using the windows software). Then I burnt a 64-bit Ubuntu 13.04 Live DVD. I disabled Secure Boot and Fast Startup (not UEFI).

I had problems with the installation, as afer selecting the install option the screen started to flash and flicker. I solved it using nomodeset and installed it. I made an 8GB partition for swap (as that's my RAM capacity), a 20GB one for root and a big one for /home. I wasn't sure if I had to make any of those primary instead of logical, but the installation ended correctly.

When I start now the PC, GRUB loads and shows me both windows 8, Ubuntu, and the Vaio system setup. BUT , if I select Ubuntu, it boots (I can hear the ubuntu welcome sound) but the screen flickers and flashes. I tried to use nomodeset, but that somehow starts Ubuntu in text mode (terminal). And if I choose Windows 8, it says that "drivemap" couldn't be found. "invalid EFI file path". The system setup boots correctly.

I'm a n00b, and I'm really lost. Help, please!


Invalid efi path;

Invalid EFI file path

grub2's os-prober creates wrong style (BIOS) chain boot entry


Do you have AMD video as specs for E models show? You also can try radeon.modeset=0 Many of the new systems seem to also require other boot parameters but they vary by specific model.



| improve this answer | |
  • If you only wanted to offer the links, please consider changing this into a comment. Otherwise, try to edit it into a full-blown answer, instead of a collection of links and questions to the OP. Use the links for reference where possible. – edwin Aug 8 '13 at 4:33

There are several possible solutions to the Windows boot bug. Three of these are:

  • Use Ubuntu's Boot Repair tool. You'll probably have to run this from a live CD (like your installer).
  • Install my rEFInd boot manager. Do this from Windows and install the driver for the filesystem on which your Linux kernel resides (probably ext4fs) for best results. There's a slim chance that booting Ubuntu directly from rEFInd will fix your video problems, too, but that's not likely.
  • Edit the /etc/grub.d/40_custom file in Ubuntu and add an entry for Windows. Once this is done, type sudo update-grub to fix the GRUB configuration. You'll obviously need to do this from a text-mode boot or from a live CD unless you can fix your Ubuntu video problems first.

Something like the following will probably work for the final option, although you'll need to fiddle with the details, and particularly the (hd0,gpt1) bit:

menuentry "Windows 8" {
    insmod part_gpt
    insmod chain
    set root='(hd0,gpt1)'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi

As to the Ubuntu video problem, there seem to be a lot of issues like yours of late, probably because of Linux video driver issues. Sometimes adding a hardware-specific kernel option will help, as oldfred has suggested; but I don't know the details of what's necessary on specific systems, and you haven't said what your video hardware is. As a generic fallback suggestion, the following might help (but don't get your hopes up too high):

  1. Add single to the boot options.
  2. You'll get to a prompt that asks for a root password or to press Ctrl+D. Press Ctrl+D.
  3. The system will give you a login prompt. Log in with your regular username.
  4. Type sudo su to acquire root privileges.
  5. Type cp /root/xorg.conf.new /etc/X11/xorg.conf
  6. Reboot, and this time use the regular boot options.

This might not work right away, and in fact it's conceivable that it will make matters worse. If so, you can use a live CD to delete the /etc/X11/xorg.conf file. If this procedure doesn't help, or if it helps a bit but not enough to make you happy, you might be able to get it working by editing /etc/X11/xorg.conf. Unfortunately, editing this file is a complex topic. Googling "editing xorg.conf" returns lots of hits, but I have no specific recommendations for what site to read. If you take some time to learn, it's conceivable that you'll get it working. Broadly speaking, you probably want to eliminate all but the first Screen definition from the ServerLayout section, and play with which specific definition it uses (Screen0, Screen1, etc.). If you make progress but can't quite get it perfect, try posting another question or (better) post on a Web forum or on IRC. (This site isn't really ideal for interactive debugging.)

| improve this answer | |
  • Thanks for your answer! I can't run boot repair because the Live CD's "Try Ubuntu" option also loads in terminal mode (I tried running it by terminal but it seems that it's not possible without graphics). And I can not install rEFInd boot manager as I can't access windows :S If by running boot repair I could fix the windows problem, then the key problem must be ubuntu's graphics. Mi video card is an Advanced Microdevices Radeon HD 7550M 1GB. – user182298 Aug 9 '13 at 2:37

I found the solution here: http://www.linuxtechtips.com/2012/12/amd-radeon-hd-7670m-on-ubuntu-1204.html

It's not for the 7550M, but it more or less works good enough to use the graphic enviroment to actually install the proper drivers.

Boot-repair actually solver the windows problem, so it's all fixed now!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.