ok ladies and gents. Im pretty new at this. I have gone through a quite lengthy set-up process of acquiring a working copy of ndiswrapper. Currently i am running Ubuntu 12.04 amd-64-lts. My wireless hardware is Netgear wna3100. I have gone and read countless times that people have issues with ndiswrapper having missing modules. I worked around it by installing Ndiswrapper 1.58 as suggested on another help site.

The current issue at hand is i can load drivers found on the web that are "meant" for my card. These drivers work albeit not well as my bandwidth is capped at 5mbps. This shows me a real-time speedtest.net test of around 4-5mbps quite slow considering when i plug in another wireless usb Netgear wna1100 i see around 30mbps down.

Yes i know you will say "you have a working usb card." Indeed I do, however I would prefer the higher bandwidth usb card as it is twice the connect speed through windows.

Back to the issue at hand. I have deleted the necessary .inf driver files from ndis-gtk and also removed them from ndiswrapper successfully. The issue is that when I pull the real driver from my windows installation directory bcmwlhigh6.inf i get the whole "hardware not present ndis-gtk. I Then sudo modprobe ndiswrapper in console. Plug the usb card in just like the process for the bogus driver. No blue light :-/

At that point i pulled the usb from the cradle. Sudo reboot. Let my system power up and sudo modprobe ndiswrapper, plugged in the usb and still no blue light.

What should i do? Ndis-gtk shows it blatantly on the gui that my card is indeed plugged in. This process works for the bogus driver yet wont work for the real one from a windows install, I find this highly irregular.

All of my limited experience with ndiswrapper have gone fairly smoothly with exception of the 1.57 glitch that most of us on 12.04 had. I cant run this card at 5mbps when its capable of over 100 wirelessly. I do a fair amount of gaming so please help.

For the record I have no error logs as the install of 1.58 was seamless.

Excuse me for my lengthy explanation, it has just been one of those days.


  • 1
    When you transfer the 'real' driver, is it a Windows XP .inf and .sys file? Please see: man ndswrapper. It says, "ndiswrapper is two parts: user space tool that is used to install Windows XP drivers and kernel module to load the Windows XP drivers. Both are called ndiswrapper." I doubt bcmwlhigh6.inf is correct. Please edit your question to add: lsusb. – chili555 Aug 7 '13 at 22:59
  • The real driver is a windows 7 version of the driver. I am using bcmwlhigh6.inf. I found this in the dir C:/programfiles/netgear/wna3100 as that is where the files were unpackaged. I have also installed it from an installer from netgear website and found the same driver when unpacked in wine's virtual c: drive. I am at a loss. Below is a copy of the lsusb and lsmod files – N1sM Aug 8 '13 at 18:46
  • Where is lsusb?? – chili555 Aug 8 '13 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.