The Ubuntu installation does not create swap partition. This issue happen with both 12.04.2 and 13.04.

I tested it with two diferents pc and with a virtual machine in virtual box into Ubuntu. I tried both automatic and manual installation options during installation.

The partition is created but with errors and the system can not mount the partition swap at startup.

I solved the problem by booting the system from pendrive, then start gparted and format the partition again. This worked for only a few days.

  • Did you do anything in particular while installing? Like Full Disk Encryption or set up Logical Volume Manager (LVM)? – Braiam Aug 7 '13 at 22:18
  • What is the content of /etc/fstab? – smonff Aug 8 '13 at 13:48
  • Thanks for your answer. Yes, while i installed the system i choosed the option to encripted the home partition. But i always do this since 10.04, and never had this problem. – tres86dx Aug 13 '13 at 23:33
  • the content of /etc/fstab is:file system> # / was on /dev/sdb1 during installation UUID=59a5ed6f-0962-4146-b993-11e0251226b8 / ext4 errors=remount-ro 0 1 # /home was on /dev/sdb6 during installation UUID=3d3b2e50-5705-46de-a7cb-7bdc590243cf /home ext4 defaults 0 2 # swap was on /dev/sdb5 during installation #UUID=ad6834c0-9b81-45fe-a067-9595eb567c7c none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 – tres86dx Aug 28 '13 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.