I recently installed Ubuntu onto my Dell Inspiron 1545 laptop.

I can connect to the Internet via Ethernet, but wireless won't work. The prompt to put in the wifi password pops up, but when I put in the password, it simply says connecting and the prompt for the password comes back up! The prompt will come back up every two or three minutes, but the same thing happens.

I've tried to install drivers using Windows Wireless Drivers, but I can't seem to figure it out. My wireless card is an Atheros AR928X. This is my first time using Ubuntu.

Here is the output of the commands I've been asked to run:

1- Output of lspci -nnk | grep -iA2 net

$ lspci -nnk | grep -iA2 net
09:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller [11ab:4354] (rev 13)
    Subsystem: Dell Device [1028:02aa]
    Kernel driver in use: sky2
0c:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
    Subsystem: Atheros Communications Inc. Device [168c:0200]
    Kernel driver in use: ath9k

2- Output of lsusb

$ lsusb
Bus 001 Device 003: ID 0c45:63ee Microdia 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

3- Output of nm-tool, sudo iwlist scan and iwconfig

$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            sky2
  State:             connected
  Default:           yes
  HW Address:        00:25:64:44:02:7D

    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Prefix:          24 (


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             disconnected
  Default:           no
  HW Address:        00:22:5F:C2:08:1F


  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    beau:            Infra, 00:26:B8:ED:E6:CC, Freq 2422 MHz, Rate 54 Mb/s, Strength 95 WPA
    verjee:          Infra, F0:D1:A9:14:03:7A, Freq 2452 MHz, Rate 54 Mb/s, Strength 32 WPA2

$ sudo iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:26:B8:ED:E6:CC
                    Frequency:2.422 GHz (Channel 3)
                    Quality=64/70  Signal level=-46 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Extra: Last beacon: 36ms ago
                    IE: Unknown: 000462656175
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030103
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A6C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1603001300000000000000000000000000000000000000
                    IE: Unknown: DD090010180202F0050000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP

                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C336C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3403001300000000000000000000000000000000000000
          Cell 02 - Address: F0:D1:A9:14:03:7A
                    Frequency:2.452 GHz (Channel 9)
                    Quality=27/70  Signal level=-83 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 3636ms ago
                    IE: Unknown: 00067665726A6565
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 0706434120010B1E
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1AAD511BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 33027E9D
                    IE: Unknown: 3D1609080400000000000000000000000000000000000000
                    IE: Unknown: 46050200010000
                    IE: Unknown: DD180050F2020101010003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0700039301730B20
                    IE: Unknown: DD0E0017F20700010106F0D1A914037A

$ iwconfig 
wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

eth0      no wireless extensions.
Authentication Suites (1) : PSK

4- Output of rfkill list all

$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

5- Output of lsmod

$ lsmod
Module                  Size  Used by
bnep                   17791  2 
rfcomm                 38104  0 
bluetooth             189625  10 bnep,rfcomm
parport_pc             32115  0 
ppdev                  12850  0 
snd_hda_codec_idt      60238  1 
arc4                   12474  2 
snd_hda_intel          32983  5 
snd_hda_codec         116477  2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13277  1 snd_hda_codec
joydev                 17394  0 
ath9k                 122028  0 
mac80211              475546  1 ath9k
snd_pcm                81124  3 snd_hda_intel,snd_hda_codec
snd_seq_midi           13133  0 
snd_rawmidi            25426  1 snd_seq_midi
snd_seq_midi_event     14476  1 snd_seq_midi
ath9k_common           13782  1 ath9k
ath9k_hw              384090  2 ath9k,ath9k_common
i915                  479235  4 
uvcvideo               72249  0 
snd_seq                51594  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28932  2 snd_pcm,snd_seq
snd_seq_device         14138  3 snd_seq_midi,snd_rawmidi,snd_seq
videobuf2_core         32212  1 uvcvideo
ath                    19436  3 ath9k,ath9k_common,ath9k_hw
drm_kms_helper         47459  1 i915
cfg80211              181041  3 ath9k,mac80211,ath
drm                   240443  5 i915,drm_kms_helper
psmouse                91381  0 
videodev              100265  2 uvcvideo,videobuf2_core
snd                    62675  18 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
videobuf2_vmalloc      12757  1 uvcvideo
videobuf2_memops       13213  1 videobuf2_vmalloc
dell_wmi               12602  0 
coretemp               13362  0 
sparse_keymap          13659  1 dell_wmi
gpio_ich               13160  0 
wmi                    18745  1 dell_wmi
dell_laptop            17210  0 
microcode              18396  0 
dcdbas                 14099  1 dell_laptop
soundcore              14636  1 snd
snd_page_alloc         14109  2 snd_hda_intel,snd_pcm
serio_raw              13032  0 
lpc_ich                16993  0 
i2c_algo_bit           13317  1 i915
mac_hid                13078  0 
video                  19117  1 i915
lp                     17456  0 
parport                40931  3 parport_pc,ppdev,lp
ums_realtek            17929  0 
usb_storage            39720  1 ums_realtek
ahci                   25621  2 
libahci                26166  1 ahci
sky2                   53629  0 

6- Modprobing

 echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
options ath9k nohwcrypt=1

sudo modprobe -rfv ath9k
rmmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
rmmod /lib/modules/3.5.0-37-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/3.5.0-37-generic/kernel/net/wireless/cfg80211.ko

 sudo modprobe -v ath9k
insmod /lib/modules/3.5.0-37-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/3.5.0-37-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/3.5.0-37-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1

7- Output of dmesg | egrep 'ath|firm|wlan|network|wpa'


Any and all help is welcome!

  • Please open the terminal(ctrl+alt+t) run the commands one line at a time: lspci -nnk | grep -iA2 net lsusb nm-tool sudo iwlist scan iwconfig rfkill list all lsmod post the output at pastebin.com then post the link here. Thanks – Wild Man Aug 7 '13 at 19:28
  • @WildMan, please add the commands in more readable manner! :) – edwin Aug 7 '13 at 19:45
  • pastebin.com/1pc2fNBQ – user182232 Aug 7 '13 at 19:52
  • @edwin I do not know how to make the commands more readable in comments, I have tried before and this is the best I came up with. – Wild Man Aug 7 '13 at 21:32
  • Sorry, should I enter the entire "sudo cat /var/log/syslog | grep -e ath -e firmware | -e wlan -e wpa -e etork tail -n45" Or is each line a command that should be entered? – user182232 Aug 7 '13 at 23:18

I had this same issue with a RealTek RTL8188EEE wireless card and Ubuntu 13.04. The quick solution was to just put in the IP of my Wireless Router, then change it from AES to TKIP-AES. This kept the other systems on my wireless happy, and suddenly Ubuntu took the password and connected me with a reported 72Mb/s connection speed.

I couldn't do too much more since I was running from the DVD, making sure it works before I install. I had seen suggestions of doing NDISWrapper and then rebooting - not gonna help with the DVD.

Hope this helps anyone else looking. Probably too late to help the original person posting, but maybe it will help someone else. If you can't do TKIP-AES, try going from AES to just TKIP. That was suggested in another forum as well.

  • Yep, this did it for me. I changed my router to use TKIP instead of AES. – Mirthquakes Sep 28 '14 at 20:41

Please copy and paste the commands for accuracy one line at a time:

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

sudo modprobe -rfv ath9k

sudo modprobe -v ath9k

Also it would be best to set encryption in the router to just wpa2 if you have that option by entering or something very similar to those numbers in your web browser while having an ethernet connection, you may have to look at the documentation for your router for the exact numbers to enter.

Also try channel 1 or 11 in your router.

You can google the documentation for your router. Please set your wireless settings in network manager to match the screenshots.wireless settingswireless settings

You should also remove your connection in network manager and reset your router then reboot your computer.

  • pastebin.com/2fjtMnPy – user182232 Aug 7 '13 at 21:29
  • Cant seem to find the router documents at the moment. Will comment if found. (Thanks for the help btw) – user182232 Aug 7 '13 at 21:30
  • I would run the commands and see if that makes it connect then you can look up router documentation if needed. – Wild Man Aug 7 '13 at 21:34
  • Wireless still not connecting. I still can't find the documents. Any other suggestions? – user182232 Aug 7 '13 at 21:59
  • I've gone through the entire answer, step by step, but the wireless won't connect. I think here is where I admit defeat. Thank you all, especially Wild Man,for all the help. I think I have to crawl back to Windows now... Again, thanks for all the help. You guys were awesome! – user182232 Aug 8 '13 at 17:56

Make sure you have wireless-tools installed via sudo apt-get install wireless-tools

This will provide a better GUI to connect to existing wireless networks.

Try pinging any site, local computer or not, to test if it is working. You may get a specific error, which may mean that some of the settings are off.

  • When put into the terminal, it comes back saying that the wireless tools are already the newest version. – user182232 Aug 7 '13 at 22:10
  • What Ubuntu version are you using, and what desktop environment? (Unity is default, if you just installed) – Mobo Aug 7 '13 at 22:20
  • Version 12.04 LTS. I am assuming that the desktop environment is "Unity" as I don't recall making any changes like that. – user182232 Aug 7 '13 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.