I have a USB live key created with Linux Live USB creator. I used all the defaults, and got a standard version of Ubuntu. When I try to boot into it, I get the error above. I went through the rest of the threads with no avail.

Things I tried:

  • Renaming the files (my files were already syslinux.cfg, etc.)
  • Typing in mboot.c32 -c boot.cfg into the boot:__ prompt

Any help would be appreciated!

  • Syslinux.cfg? It should be syslinux.cfg Below answer is the solution so if this does not work you probably made a mistake somewhere ;-)
    – Rinzwind
    Aug 7 '13 at 12:21

General answer

Generally the iso image that are intended to be burned and booted from CD/DVD has all the files required for boot in the isolinux folder. Whereas the iso images that are intended to be run from USB has all the files required for boot in the syslinux folder. So when you try to burn and boot a CD/DVD iso from USB, it cannot recognize the type of boot medium as it will not have syslinux folder it will simply give Boot failure : No DEFAULT or UI configuration directive found!.

General solution for the Error

Open the USB installation media, then rename the following:

isolinux –> syslinux (folder)
isolinux.bin –> syslinux.bin
isolinux.cfg –> syslinux.cfg

The system looks for these two files (.bin & .cfg) in the syslinux folder at root of the device. So make sure you have both files in the syslinux folder.

  • 1
    He already mentioned in the question that he tried renaming the files/folders.
    – Alaa Ali
    Aug 7 '13 at 12:29
  • @Alaa I know and this IS the correct method. And as you can see he posted "Syslinux.cfg" If that is the case he did not follow the correct procedure.
    – Rinzwind
    Aug 7 '13 at 12:32
  • Yeah, I guess I'm just saying that we shouldn't post an answer until we make sure that he actually renamed to Syslinux and not syslinux, because then it would be a duplicate of this (but from the steps he tried, I'm guessing he followed the answers in that question anyways). Also, he mentioned that his files were already syslinux, so I don't think he renamed anything in the first place =).
    – Alaa Ali
    Aug 7 '13 at 12:42
  • @alaa but anyone else that comes here will have a complete answer ;)
    – Rinzwind
    Aug 7 '13 at 14:32
  • 3
    This resulted in Couldn't find kennel image: /isolinux/isolinux.cfg Aug 25 '18 at 22:13

I've been having the exact same problem. I tried to make USB Live with YUMI and Unebootin with the same error mistake:

SYSLINUX: No DEFAULT or UI configuration directive found!

I've tried to

  1. change isolinux etc to syslinux (by copy paste, so there's no spelling mistake)
  2. format USB to FAT16 instead of FAT32
  3. format USB to FAT16 instead of FAT32 and renaming those files (copy paste)

all failed.

Then I tried to use Universal USB Creator (same as YUMI but Windows version), and it works!

Just giving alternative suggestions if all you tried failed!

  • 1
    Thanks man, I don't quite remember how I fixed the problem, but I'm pretty sure I did it through the program you suggested. For future readers, this works!
    – Carpetfizz
    Oct 26 '13 at 23:33
  • 1
    Formatting as FAT16 solved this for me; nothing else mentioned in this thread or others was helping.
    – tremby
    Jan 30 '15 at 12:21

It seems for everyone it has a different solution, for me, the solution was to format my Flash drive with the FAT filesystem and make a boot drive with the Universal USB installer and voila, worked like a charm.

  • I did this as well, then noticed that the BIOS had set the OS to 'Windows'. Setting the booted OS to 'Other' in BIOS, along with booting from the USB installer in compatability mode worked for me. Jun 8 '15 at 3:22
  • that worked for me as well
    – Jan Groth
    May 7 '16 at 7:51

A corrupted download caused this issue for me. Rather download using the provided torrents at http://www.ubuntu.com/download/alternative-downloads


I know this is super late but just in case anyone else has the same problem. I had this same issue on my USB flash drive. Well I figured out it was because I had deleted everything from my flash drive and just moved the ISO and the installer back to the drive. (I only deleted it all because I had tried to install two different OS on the same USB and it was messing up my Ubuntu and I couldnt figure out what wasn't Ubuntu so I deleted everything.)

So the problem was that I had just highlighted and moved those two files back on the usb stick and it didn't go back to working right until I went back in and ran the installer like before (I used the Universal USB one) and it will go through the whole renaming the disk and everything. Then when it finished I noticed all of those files I had deleted. After that it was all back to normal.

Also I re-downloaded both Ubuntu and the installer just in case (but Im sure it was nothing wrong with the original downloads now).

So if you get that error, first think back if you accidentally deleted any of your Ubuntu files from your flash drive. This is probably not the case for the original poster but for anyone who happens across this thread as I did who has tried all of those options, maybe this will help you.

Not the answer you're looking for? Browse other questions tagged or ask your own question.