15

In the left side of the screen there are icons: Software Center, Ubuntu One, etc. System icons can be seen but icons of the programs that I have installed can not be seen. Rather there is a "?" for the icons. How can I solve this problem?

23
+50

.desktop files control the behavior of launcher shortcuts in Linux. To check the icon in use, you will need to open the appropriate .desktop file that is located in either /usr/share/applications or in ~/.local/share/applications by typing the following command: (I'm assuming you installed Eclipse from the software center, so the more likely option is in use:

sudo -H gedit /usr/share/applications/eclipse.desktop

If this file is empty, you will need to exit without saving, and substitute the path in the command. Go down to the line marked Icon= and if there are any comments in it (designated by #), remove this comment, as i have heard of a bug that causes the icon to display, however i don't know if it has been fixed as yet.

If there is no Icon= line, find an appropriate icon in .png format and put the full path in this line including the Icon=.

Edit:

From the comments, you have said that you are running this from a link on the desktop. The proper way to do this would be to create a desktop launcher and asscociate the icon from it. To do this, open a terminal and type:

gedit ~/Desktop/eclipse.desktop

this will open a blank document. To make it a launcher add this to the file, substituting the correct paths for both the Exec= and the Icon= lines:

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Eclipse
Comment=Eclipse
Exec=<path_to_eclipse>/eclipse
Icon=<path_to_eclipse>/icon.xpm
Terminal=false
Type=Application
Categories=GNOME;Application;Development;

Save and close, then make the file executable by typing chmod +x ~/Desktop/eclipse.desktop

Now, when you open this shortcut, the icon set will appear in the launcher.

  • I did not install eclipse from Software Center. – ihsan kocak Aug 17 '13 at 6:25
  • and i could not find any file having extension of desktop. – ihsan kocak Aug 17 '13 at 6:31
  • Are you trying to do this in GUI or command line? By Default the GUI hides the .desktop when they are given Execution permission. The way to do it in Nautilus is to browse to File System > usr > share > applications find the Eclipse shortcut, right click then click Properties, click on the Icon in the top left, then browse to a suitible icon. – ScottC Aug 17 '13 at 10:51
  • There is not any eclipse icon in usr->share->applications – ihsan kocak Aug 17 '13 at 11:55
  • Just for clarification, are you running Eclipse from an icon on the launcher or dash, or are you running the command to open eclipse from the command line (or from within Nautilus for that matter)? – ScottC Aug 17 '13 at 12:25
8

I had that problem and I fixed it (I use eclipse neon)

1) sudo gedit /usr/share/applications/eclipse.desktop

2) add the following text to the file:

[Desktop Entry]
Name=Eclipse 
Type=Application
Exec=env UBUNTU_MENUPROXY= <path_to_eclipse>/eclipse
Terminal=false
Icon=<path_to_eclipse>/icon.xpm
Comment=Integrated Development Environment
NoDisplay=false
Categories=Development;IDE;
Name[en]=eclipse.desktop

3) sudo desktop-file-install /usr/share/applications/eclipse.desktop

4) cd /usr/local/bin/

5) sudo ln -s <path_to_eclipse>/eclipse

6) sudo cp <path_to_eclipse>/icon.xpm /usr/share/pixmaps/eclipse.xpm

IT WORKS! I have no more Question mark!

  • 1
    This answer has a few serious issues, a few important ones: never use sudo on GUI applications, never edit the original .desktop file, copy it to ~/.local/share/applications, I find it hard to believe the (original) file included the line Icon=/icon.xpm etc etc. – Jacob Vlijm Jul 1 '16 at 14:15
1

You could try installing Unity Tweak and making sure your applications have an icon theme selected. If that doesn't work try installing a different icon theme and see if it updates your icons. If that doesn't work report back because you probably have a different issue all together.

0

If you have an open project, to get to the launcher you have to go to File -> Close Project first, then Configure -> Create Desktop Entry

0

I had the same problem when I open PhpStorm from the JatBrains Toolbox.

The jetbrains-phpstorm.desktop file was ok in ~/.local/share/applications folder but the app opened with question mark. The problem was that there was a .desktop file in /usr/share/applications that was created when I had an older version of PhpStorm and the icon from that file pointed to a file that did not exist.

I removed the .desktop file from /usr/share/applications and this resolved the problem.

Now I have the correct icon and I guess that the .desktop file used is the one from ~/.local/share/applications folder.

I hope this helps other with this problem.

0

In my case, when I pin GitKraken to show in Task Manager (Arch Linux/openSUSE 15) and then close the GitKraken application, I see only a question mark instead of the correct icon.

This is due to a missing file, gitkraken.svg, in /usr/share/icons/hicolor/scalable/apps.

I solved this by copying this icon to /usr/share/icons/hicolor/scalable/apps.

I hope this will help others having this issue.

  • Hi! I suppose that you mean task bar instead of task manager, right? – user3140225 Sep 16 at 17:14
  • Yes, exactly ... I use Linux distros and if you click on the "task bar" you will see "Task Manager Settings ... " ... that's the reason why I use this name. – Vasil Stoyanov Sep 17 at 8:23
  • I see. You are probably using the KDE desktop environment. In some environments, for example in XFCE, task manager refers to the system monitor, that's why I wanted to clarify this. Perhaps "panel" is a term that is less DE-specific. – user3140225 Sep 17 at 8:33
  • I got it. Yes, you are absolutely right. All my comments are related to KDE desktop environment. – Vasil Stoyanov Sep 17 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.