3

I just discovered that many Gnome dialog boxes do have keyboard shortcuts to reach controls or tabs with Alt+letter — only they are not displayed. The shortcuts do appear in the form of an underlined letter when I hold Alt down.

How can I make the shortcut letter always underlined, so that the shortcuts are discoverable? Same question for menu items, by the way.

What I see normally:

no underline

What I see with Alt held down, and I want to see all the time:

with underline

I found https://stackoverflow.com/questions/10103922/gnome-3-always-show-altx-keyboard-shortcuts, which suggests adding gtk-auto-mnemonic = 0 to ~/.gtkrc-2.0 for Gnome 2 and dconf write /org/gnome/desktop/interface/automatic-mnemonics false for Gnome 3. Neither seems to have any effect in my session though.

In Ubuntu 12.04, in my sessionafter setting automatic-mnemonics to false, shortcut letters still don't appear unless I hold Alt down (I tried in pavucontrol, evince and gnome-control-center). I start my session from Lightdm and I am not running a Gnome session. My window manager is Sawfish. I do have a D-Bus daemon, and other dconf settings take effect immediately (e.g. /org/gnome/desktop/background/draw-background). If I start another session with startx on the same machine, the change of automatic-mnemonics is not reflected. However, if I run a default (Unity or Gnome) session in a different account, automatic-mnemonics takes effect immediately.

0

The dconf method works for me on 12.04. What you may try:

  • Are you modifying the dconf entry for the same user as with you launch the applications. (e.g. don't use sudo) The dconf settings are per-user.

  • Is your ~/.config/dconf/user file writeable by your user?

  • Maybe that file is corrupted. Try making a backup of the ~/.config/dconf/user file, and then remove it. Logout, login and then try again the dconf settings with the newly generated file.

  • All my other dconf settings work, so I don't see how it could be a dconf issue (and anyway, no, I'm not doing anything weird like running applications as another user). – Gilles 'SO- stop being evil' Jan 29 '14 at 11:47
  • @Gilles Have you tried modifying the /usr/share/glib-2.0/schemas/gnome.desktop.interface.gschema.xml file directly, changing the appropriate automatic-mnemonics key to false? If this works, then you can make an override file for this, though this will change this preference for every user, which might not be suitable for you. – falconer Jan 29 '14 at 12:36
  • Changing automatic-mnemonics to false in /usr/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml doesn't make any difference (I checked in a new session). I'm not using Cinnamon, I only have official Ubuntu packages installed. – Gilles 'SO- stop being evil' Jan 29 '14 at 13:26
  • @Gilles If you change that .xml, you will also have to run sudo glib-compile-schemas /usr/share/glib-2.0/schemas to recompile the schemas. But before that: backup the /usr/share/glib-2.0/schemas/gschemas.compiled file, just in case, this file will be changed by the recompile. After that you have to logout-login to see the effects. – falconer Jan 29 '14 at 13:35
  • This doesn't change anything in my session or in a new session. I tested the normal dconf write method and it does work for a fresh account (starting with an empty home). What I haven't tried is logging out completely (maybe my second session was communicating with a D-Bus process from the first session?). I'll do that when I get a chance to log out or fire up a test VM. All other gconf/dconf settings I'd tried took effect immediately, so I wonder why this one would require a completely fresh login (if that turns out to be the issue). – Gilles 'SO- stop being evil' Jan 29 '14 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.