I followed the instructions at this site to get pure Lubuntu. Unfortunately, after doing so my computer will no longer boot into the GUI. I'm able to switch over to a terminal just fine, but the GUI never comes up. The computer boots past the Lubuntu splash screen and then displays:

apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName 
* Starting web server apache2
etc/rc2.d/S99acpi-support: line 7: /usr/share/acpi-support/power-funcs: No such file or directory

It seems to be stuck there. Yesterday, I let the computer run for 24 hours. When I came back, the whole screen was full of code. I didn't catch any of it though.

I attempted to restart from a Live USB, but the computer wouldn't even recognize it. I tried it in every port but I can't get it to show up on the boot menu.

I was able to Ctrl+Alt+F6 to a terminal. I tried:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall lubuntu-desktop

I also tried sudo apt-get install -f.

None of this helped. Now it's just back to the aforementioned apache2 error message.

Another oddity: I can reboot the computer from the terminal using sudo reboot but when I attempt sudo shutdown now it pumps out a ton of error messages, switches to single user mode, and waits for a command.

How can I get my GUI back?


I realized that I was stupidly trying to boot a computer with UEFI using an x86 USB. It boots from a live USB using the 64-bit live USB.

  • 1
    One of the first things that guide says is that the scripts may uninstall a bunch of packages that you need for other software, but you're responsible for identifying them and writing them down for reinstall later. I don't know how, but you should fish out a log of the package changes you made somehow, and track down those non-ubuntu related packages. – Alex Aug 7 '13 at 2:49
  • Take a look at thisPost, see if it helps. – Mitch Aug 7 '13 at 6:49
  • @Mitch No change – jimchristie Aug 7 '13 at 13:18
  • Are you sure etc/rc2.d/S99aspci-support: line 7: /usr/share/aspci-support/power-funcs: No such file or directory is not a typo? Watch the aspci instead of acpi, I think correcting that would help? Maybe shutdown now gives error because of acpi-support is messed up? – Samik Aug 15 '13 at 11:58
  • @EliahKagan I have not found the answer to the main thrust of the question: the GUI won't boot. The only thing I figured out was that I was stupidly trying to boot from a USB with the wrong USB. I still don't have the GUI back when I take the USB out. Sorry if I was unclear. – jimchristie Aug 15 '13 at 20:19

Its possible you removed the lightdm, which is the login window. This is what gets you into any flavor of Ubuntu, its where you login. Try reinstalling this. And, the apache2 has nothing to do with this problem, thats a whole nother problem completely. You most likely removed as well, many key files...I would back up your files using a live boot and re-install lubuntu, purely...

  • No luck reinstalling lightdm. And yes, I could wipe the computer and start from scratch, but I'd really like to avoid that if at all possible. – jimchristie Aug 14 '13 at 17:12
  • If they are getting the Lubuntu splash screen, they are probably going past the lightdm stage okay. – Sparhawk Aug 16 '13 at 1:10

In the terminal, type-


maybe it brings up the GUI

  • If the above doesnt work, as a workaround I could suggest installing all the packages that you uninstalled, so that you could at least get your Ubnutu GUI back. – aaditya1234 Aug 13 '13 at 14:55
  • No luck with startx. And reinstalling all the packages that I uninstalled is somewhat counterproductive. I'd rather just find the specific thing that's causing the problem and fix that. – jimchristie Aug 14 '13 at 17:08
  • ok..takes a lot of patience to do that! – aaditya1234 Aug 14 '13 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.