-1

After updating today, 13.04 no longer shows Unity panels.

I tried the guide to reporting from console, but it always shows "please fill out the form in the automatically opened web browser". Is there no way to finish reporting a bug from console, or another computer?

https://help.ubuntu.com/10.04/serverguide/reporting-bugs.html

Btw Ctrl+alt+T works for me, when the keyboard input doesn't go to pidgin, that is. ubuntu-bug /var/crash/_usr_bin_compiz.1000.crash does not pop up a browser window.

I tried this, and it doesn't help, I still have the same problem after resetting. How do I reset my Unity configuration?

Does this happen on all machines with Intel Mobile GM965/GL960 Integrated Graphics Controller?

--Update--

I've filed a bug report, it is now marked as "high" importance, triaged. The question is, how old of a computer is "supported" with the latest releases of Ubuntu? This machine has also been affected by the jittery titles in Chromium bug, and a general slowness that made me wonder how supported the graphics-card was.

I've seen much older (P4 era) computers running 12.x Ubuntu, but I suppose the newer releases don't go through as much testing on even 5-year-old machines? Is there any documentation on what QA practices Ubuntu uses on updates, and major distribution upgrades?

closed as off-topic by bain, Eric Carvalho, user.dz, Panther, belacqua Jul 1 '14 at 0:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • You can open a tty by doing ctrl+alt+f1 and then logging in and executing that ubuntu-bug command, right? That will prevent it from loading a GUI window and will do CLI prompts only. – Thomas Ward Aug 7 '13 at 1:39
  • Yes, but it still says "please fill out the form in the automatically opened web browser". Even when I run it in graphical mode it doesn't pop up a browser. – NoBugs Aug 7 '13 at 1:52
  • It should provide you a link to copy into a web browser, no? – Thomas Ward Aug 7 '13 at 2:14
  • @ThomasW. No link, just exited – NoBugs Aug 7 '13 at 2:17
5
+50

forget about completing the report from the console. just save the report as a .apport file from the cli. (the link you had given shows how). You can then upload the details in your own sweet time after your computer is up and running (which is more urgent)

$apport-cli unity

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
.................................

*** Send problem report to the developers?

After the problem report has been sent, please fill out the form in the
automatically opened web browser.

What would you like to do? Your options are:
  S: Send report (5.5 KB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C): K
Problem report file: /tmp/apport.some-rubbish.apport
$cp /tmp/apport.some-rubbish.apport ~/unity-report.apport
$

Now, to forcible reset all you settings, do this from a VT (i.e. ctrl+alt+f1):

$ mkdir configbak
$ for i in .[^.]*; do mv "$i" configbak/ ; done

this will move all your configuration files to a backup directory. When you login, it will be as though you have never logged into that account before.


If this doesn't fix it, try force reinstalling. see How can I remove and re-install Unity? for a set of commands to run.


O.K.

Time to try bisect the problem: you can use fluxbox(if from a live system) => graphics partly ok. To make sure that the 3D stack of ur installed OS is ok, try putting another DE that has similar graphics requirements.

apt-get install gnome-shell

if that works AND resetting your config files does not help, then you can narrow the problem to all of the many packages and system configs that are unique to compiz & unity.

sudo bash
apt-get remove 'compiz*'
apt-get remove 'unity*'
apt-get purge 'compiz*'
apt-get purge 'unity*'
apt-get autoremove

apt-get install unity

agree to remove all packages that autoremove suggests removing. If even this doesn't work (AND u can live boot into a unity session, you might just be better off reinstalling)

  • Thanks, but I already reported the bug with attached .crash file. I'll try reinstalling unity. – NoBugs Aug 9 '13 at 23:50
  • The instructions on that answer are a bit old, some aren't applicable anymore, and it didn't work for me unfortunately. I wonder if this happens on all machines with Intel Mobile GM965/GL960 Integrated Graphics Controller? – NoBugs Aug 10 '13 at 0:37
  • Did you try resetting your config files? – staticd Aug 10 '13 at 6:07
  • So the problem could be to do with graphics? Try using the command jockey-text -l in Terminal and give us the output... – Ads20000 Aug 11 '13 at 7:55
  • The problem could be the graphics, but it seemed to be working in fluxbox, so I doubt it. The problem only started after running some updtes, so it shouldn't be bad config files either. – NoBugs Aug 12 '13 at 2:31
1

Unity's Launcher and Panel require the Ubuntu Unity Compiz plugin to be enabled, otherwise they won't show.

To (re-)enable the Ubuntu Unity Compiz plugin, open a terminal window using CTRL + ALT + T and enter the following commands

sudo apt-get update
sudo apt-get install compizconfig-settings-manager
ccsm

Scroll down to Desktop and select Ubuntu Unity Plugin. Make sure that Enable Ubuntu Unity plugin is checked. Select Back and Close.

Once finished, restart Unity by entering sudo restart lightdm in your terminal window.

  • Thanks, but that was one of the things I checked. Unity's broken. – NoBugs Aug 16 '13 at 4:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.