1

We have proxy-server, I was able to set up network connection and mozilla works perfectly, it prompts for login/password and when logged-in it works, but when I try to download any software from repository or to search for updates, the system does not connect to internet.

It does not prompt for login/password, as it does in Windows Update Center.

What is it that I need to configure?

1 Answer 1

1

You can set Proxy by adding following lines in /etc/profile

export http_proxy=http://username:password@proxyhost:port/ 
export ftp_proxy=http://username:password@proxyhost:port/

Then just reload profile using source /etc/profile. after this you can use :

apt-get update

If you are still facing same issue, then edit "/etc/apt/apt.conf" and add below entry:

Acquire::http::Proxy "http://username:password@proxyhost:port/";
3
  • Rahul Patil, I did as you suggested. Running "apt-get update" in terminal results in long list of ignored and erroneus web-adderesses like "Ign extras.ubuntu.com quantal InRelease" and "Er extras.ubuntu.com quantal/main Sources 407 Unauthorized". What's wrong now? And how I can download and install applications from repository? For example I look for gXNeur using Ubuntu application center. It locates gXNeur as available from source "universe". I click use this source. Progress icon starts running, then it stops and prompts "Check internet connection". Any suggestions? Thanks
    – javlon
    Aug 7, 2013 at 3:19
  • I have updated another option... Aug 7, 2013 at 6:09
  • if it working then select answer as correct, this is way to say thanks on this site :P Aug 7, 2013 at 9:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .