I have a Samsung Chronos 7 laptop (NP770Z5E) pre-installed with Windows 8, and I wanted to install Ubuntu 13.04 alongside it, so I can dual boot.

Here is what I've done:

  • Updated BIOS to lastest version (P04ABU) using Samsung Updater
  • Reduced Win8 partition by half, I left the others untouched
  • Created a bootable USB stick using http://unetbootin.sourceforge.net/ and a Ubuntu 13.04 64-bit image
  • Disabled FastStartup on Win 8
  • Disabled Fast BIOS Mode
  • Boot Mode changed to CSM OS


  • Also disabled Secure Boot (I had to disable it in order to select CSM OS)

After that I saved the BIOS settings, and shut down the computer. I plugged in the USB drive, powered the computer on, entered the BIOS and tried to change the boot order. Oddly, there was only one option in the boot order screen, the USB drive (HDD didn't show up in the boot priority screen).

I ignored that and installed Ubuntu. I've created 3 partitions from the unused spaced left: a 8GB swap, a 100MB BIOS boot partition, and the rest to ext4, mounted in /. Boot loader installed on /sda.

After a reboot, this message appears:

All boot options are tried.

Press <F4> key to recover with factory image using Recovery

or any other keys for next boot loop iteration.

So I went to the BIOS to change the boot device priority, and the list is empty! Enabling Secure Boot and Fast BIOS had no effect.

I used the Ubuntu Live USB to check the disk contents, I can see the Ubuntu and Win 8 partitions. I've used Boot Repair (using the Recommended Repair), with no avail, the Boot Repair log is here: http://paste.ubuntu.com/5953562/

Boot Repair showed me a message about the system being a"EFI system". I suppose that means that I should have checked out the advanced settings.

I don't know how to proceed. I don't know if it's a good idea to "recover with factory image" since I have modified the original partitions. Maybe I need to experiment with Boot Repair's advanced settings.


You installed Ubuntu in BIOS/CSM/Legacy mode using the protective MBR. You should be able to boot just Ubuntu from UEFI menu in CSM or BIOS mode. That would have UEFI off and with UEFI off, there is no secure boot option.

Some systems only boot Windows with secure boot on. Others boot with it off, but Windows is installed in UEFI mode. Since UEFI & BIOS write hardware info to system differently you cannot dual boot from grub menu but only by going into UEFI and turning it on for Windows or off for the BIOS install.

Better to install Ubuntu in UEFI mode and then you should be able to dual boot from grub menu. But some systems will only boot Windows with secure boot on and you have to boot the Boot-Repair program in secure boot mode to get to install the Ubuntu signed kernels that will work with secure boot.

It looks like Boot-Repair already converted your BIOS install to UEFI, but you do not have signed kernel so Ubuntu will only boot with secure boot off. A few system do not allow that or only allow the Windows efi file to boot. Then Boot-Repair has to do a work around and rename grub's shim to be the Windows file to may dual boot work.

Shows install with screen shots.


Also shows Windows 8 screens

Installing Ubuntu Alongside a Pre-Installed Windows with UEFI

Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot. required for UEFI & grub bug fixes


  • I avoided a UEFI install because of this: askubuntu.com/a/270144 – dusan Aug 6 '13 at 15:01
  • 1
    I finally booted Ubuntu with Secure Boot off and UEFI Mode. And there I run Boot Repair, so now I'm able to dual boot. Thanks a lot for the links. – dusan Aug 7 '13 at 1:28

I mostly agree with oldfred's response (exceptions below). In particular, it's generally best to keep all installed OSes booting in the same mode (BIOS or EFI). You do seem to have EFI-mode GRUB files, but your Boot Repair seems to have been run in BIOS mode, so there's no information on the EFI's boot order, and it's unclear if GRUB would come up when you reboot in EFI mode. Thus, you might need to re-run Boot Repair in EFI mode or deal with the boot order issue in some other way. For instance, in Windows you could open an Administrator Command Prompt window and type:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

The issues with buggy Samsung firmware that cause the computer to brick itself have been worked around, although you should be careful to use a recent kernel. (Upgrade to the latest available from the Ubuntu 13.04 repositories and you should be fine.)

I disagree with oldfred when it comes to some of the Secure Boot issues. Most notably, I have yet to hear a credible report of Windows failing to boot because Secure Boot is disabled. To be sure, I have heard reports of Windows failing to boot when Secure Boot is disabled, but such reports have always been vague and/or some other variable has been at play, giving rise to alternative interpretations of the phenomenon. I have, however, seen several credible reports of people who disable Secure Boot and have no problems booting Windows thereafter. Thus, I recommend simply leaving Secure Boot disabled, at least at first. If you want to enable it later, you certainly may (and there are at least potential security benefits to using Secure Boot), but I recommend taking it one step at a time, with Secure Boot re-enablement being one of the last (and optional) steps.

  • Ubuntu 13.04 uses the 3.8 kernel, does that (updated) kernel include the fix? – dusan Aug 7 '13 at 1:27
  • I don't recall the exact kernel version in which the fixes appeared (there have been at least two, which have addressed the problem in different ways). These fixes are critical enough that they'd have been back-ported by Canonical by now, though. This bug report on the issue indicates that a fix has been released. – Rod Smith Aug 7 '13 at 17:40
  • A comment in that bug report says that the fix is in the 3.10-rc6 kernel, so today I updated the kernel to 3.10-rc7 without problems (so far). – dusan Aug 8 '13 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.