I'm new to Ubuntu after a major windows breakdown. I'm slowly getting used to it, but I've just tried to copy files on to an empty USB 4gb flash drive (well I've actually tried two different ones) and it says there's no room to copy. I've looked at the properties of the drive - 0 free space, 0 used space. Where's my storage gone?!

I've tried emptying the trash, unmounting, remounting etc, nothings working :(

I'm not technical so if you know how to fix it please explain like I'm a dummy!

  • The output of fdisk -l, please, with your drive plugged. – Braiam Aug 6 '13 at 0:21

If you have nothing important on the drive that you are trying to recover, just reformat the drive. Since you said you are not very technical I'll give you some easy to follow instructions on how to do so.

First off, open up a terminal (ctrl + alt + t) and type the following commands:

sudo apt-get install gparted sudo gparted

This will install and open a program called gparted which is a very simple to use yet very powerful piece of software that will allow you to reformat you USB. The sudo command will prompt you for a password which should be the same as you login password.

Once gparted is open, select your USB in the dropdown menu in the top right corner of the screen.

enter image description here

The USB will need to be unmounted for you to perform any actions on it so keep that in mind. Be absolutely sure that the device you select is your USB! I have learned from personal experience that lack of attention during this step can be disastrous (accidentally wiped my entire hard drive :/).

After selecting you have selected the USB device, click on one of the colored rectangles that represent the different partitions on your USB. Your USB should only have one.

Then click on the Partition option on the menu at the top of the screen and followed by a click on the Format to option within that menu. There are several formats that will be made available to you but most USBs come pre-formatted as FAT32 so I would suggest just sticking with the default.

enter image description here

Now that you have selected FAT32 as the format, click on the green check mark just below the Partition menu option and gparted will do the rest!

enter image description here

Unless something is wrong with the hardware of the USB, this should fix your problem. I actually had this same issue just a couple days ago. Hope this helps and welcome to Ubuntu!


When using Linux and you delete a file from your USB you have to remember to empty the trash on your desktop or all the deleted files go into a folder ".trash-1000".

If this doesn't recover the space simply reformat.


It might have gone raw ? Try formatting your hard drive. That may help your case or else, run a scan for bad sectors (http://linuxpoison.blogspot.in/2008/01/howto-check-disk-drive-for-errors-and.html). Hope that helps.


I am using Ubuntu 14.04 LTS. When you delete files on a flash drive using the GUI, Ubuntu instead moves the deleted files to a hidden directory on the flash drive. The hidden directory will typically be called something like .Trash. You need to delete this hidden directory to free up the space.

1) Navigate to the flash drive's directory:

    cd /media/userName/flashDrive

2) Show all directories, including the hidden ones:

    ls -al

3) There should be a hidden directory there. On my computer it was .Trash-1000/. Now delete that file:

    sudo rm -r .Trash-1000/

Now the space should be free.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.