2

So I recently bought a MSI GT60 laptop with W8 preinstalled and I want to dual boot with Ubuntu.

I've been trying to make a live USB for 13.04 and I have not yet been able to boot into live or install.

I've used different methods to create the bootable USB:

  • Tried with UNetbootin (from W7)
  • Tried with YUMI (from W7)
  • Tried with Startup Disk Creator (from Ubuntu)

All three methods were able to boot on my work laptop (Dell precision m4600) but none worked on the MSI.

The MSI laptop boots from USB and shows the EFI boot menu it doesn't matter which option I choose, the screen will go black and nothing will happen after that.

If I boot with the same USB on my work laptop, after booting from USB it goes right to a Ubuntu-like environment and shows me two options, to install or to try Ubuntu and works as it should.

Has anyone been on the same situation? Any advice?

As far as I can tell I think of some bios/configuration (EFI?) incompatibility.

Sata configuration is set as AHCI. I have W8 installed, a second HDD and no other partitions.

0

9 Answers 9

2

I had the same issue on my GT 60 20C and was able to get it to work after a little bit of work.

First, I created a bootable USB disk with the 13.1 installation. I was experiencing the black screen issue after the first purple screen from the bootable USB disk. To avoid that issue, press CTRL right when the screen first shows up. You should see the language selection screen and right after, mode options. Before installing, press F6 and select

nomodeset

This step is very important, the installation will not continue unless that step is executed. After the installation is complete, boot up again with with the USB disk. Select the "nomodeset" option again but this time boot up the live installation (Try Ubuntu...)

Download boot-repair utility. I was not able to follow the steps from the Ubuntu webpage (something broken about apt). I installed all the debian packages manually from the sourceforge website.

There, make sure that GRUB is on your Ubuntu partition and as an advanced option set as a kernel parameter "nomodeset"

Reboot your computer and now you should be good to go.

0
1

I had a similar problem with a Live USB created using UNebootin or Ubuntu Startup Disk Creator. I would get a list of options to boot into, but after selecting one, I kept getting a message like, "insert a boot device."

Then I created a live CD using Startup Disk Creator for KDE (usb-creator-kde) and this worked fine.

Also, someone mentioned that plugging the Live USB stick into a USB 2.0 port instead of a USB 3.0 port was helpful to them. (I'm not so sure about this because USB 3.0 is supposed to be backward compatible, but you might give it a shot).

2
  • I'll give it a try today and will let you know, although I've also tried with a DVD with the same outcome. Commented Aug 7, 2013 at 14:01
  • putting stick in usb 2 port helped me. unbelievable...
    – ironic
    Commented Aug 28, 2017 at 15:03
1

Ok, here is another way...

  1. Rename /EFI/BOOT folder to /EFI/Ubuntu in the USB.
  2. Download refind bootloader (0.7.7.1..) and extract the refind folder which contains the refind_x64.efi, icons, drivers etc. to /EFI folder.
  3. Rename /EFI/refind to /EFI/BOOT
  4. Rename /EFI/BOOT/refind_x64.efi to /EFI/BOOT/BOOTx64.efi
  5. Copy /EFI/BOOT/refind.conf-sample to /EFI/BOOT/refind.conf
  6. Edit refind.conf file, comment all boot entries and add the following in the last...

    menuentry "Ubuntu" {  
            loader  /casper/vmlinuz.efi  
            icon    EFI/refind/icons/os_linux.icns  
            initrd  /casper/initrd.lz  
            options "root=PARTUUID=xxxx-xxxx rw rootfstype=vfat file=/preseed/ubuntu.seed boot=casper add_efi_memmap"  
    } 
    

    Replace xxxx-xxxx with UID of USB drive.

Happy booting!

0

In your BIOS (indeed you have an UEFI firmware), please disable SecureBoot, and if possible also the FastBoot and IntelSRT options. See https://help.ubuntu.com/community/UEFI for more info. Then reboot on your Ubuntu key.

0

There are lots of reports of the Bios needing to be updated before you can successfully
dual boot. The original uefi bioses that were distributed on laptops, etc
are generally not working with dual booting properly.
Also here is a link to a lengthy but excellent description of how to
successfully install ubuntu under a dual boot environment.
http://www.makeuseof.com/tag/tired-of-windows-8-how-to-dual-boot-windows-ubuntu/
PS Thats a nice laptop you have! :)

0

It seems like many MSI laptops have problems dual-booting Ubuntu, including my own. Here is where I posted about my problem; I have a GE72 model.

This guide looks quite promising for installing Ubuntu on MSI laptops. I don't have an SSD either, but given that step 4 involves enabling UEFI with CSM, I am quite certain that this will work (CSM refers to legacy BIOS, which should allow compatibility with Ubuntu). Once I try it myself, I will give an update.

This link has a description of someone else who got Ubuntu working on their GT60 2OC.

Hope this helps.

0

I have an MSI GT60-2PE Dominator Pro laptop. From my experience, I have failed to install Ubuntu 12.04, however everything works with Ubuntu 14.04 :)

The main issue was for me the Nvidia Optimus video card (and also the SSD RAID 0). I have used Startup Disk Creator to create a USB key. If you want to use GNOME you need to use at least gnome-shell 3.12 (the default is 3.10 with ubuntu 14.04, otherwise => black screen).

For the nvidia driver you need this ppa:

http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu

For GNOME 3.12 you need these PPAs:

http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu and http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu .

I highly recommend to use Macrium Reflect to create a backup of your Windows 8 partition before you try to modify this one.

I have just reduced the size of the window partition because when I try to move this partition my windows is broken.

-1

I had the same problem (black screen, MSI GT60) , but for me the solution was easy. I had to turn ON SecureBoot, and it worked directly (i tried everything else without success before that). Can't explain why ...

1
  • 1
    Umm, it does answer the question: turning on SecureBoot fixed the problem.
    – Olli
    Commented Feb 10, 2014 at 17:33
-1

Archlinux is working flawless in uefi mode on my GT60-2OD. from archlinux grub menu I can boot Ubuntu ISO as loopback in uefi mode successfully without any kernel option.

to try..

  1. install archlinux in uefi mode
  2. copy the Ubuntu ISO (ver 13.10) to the /boot/iso folder (iso folder to be created)
  3. add the following menu in /boot/grub/grub.conf...

    menuentry "ubuntu-13.10-desktop-amd64.iso" --class iso   
    {  
    insmod loopback  
    insmod iso9660  
    #insmod fat        # If ISO is located on fat16 or fat32 formatted partition.  
    set isofile="/iso/ubuntu-13.10-desktop-amd64.iso"  
    loopback loop (hd1,gpt1)$isofile  
    linux (loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=$isofile noeject noprompt --  
    initrd (loop)/casper/initrd.lz  
    }  
    

Note: (hd1,gpt1) to be changed, by checking the isofile location in grub command prompt.

it is working for me.

edit: Jack's answer is also working...Turn on Secure boot and boot from USB.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .