I installed Ubuntu 13.04 a few days back, dual-booting with Windows. I mainly use Python 2.7, so I installed that (I downloaded the .tar.gz file from python.org), but for some reason (_tkinter could not be found), I could not use Tkinter. I tried various ways of installed Tkinter/Tk, but they didn't work, so I thought I should uninstall it and reinstall it. In the terminal, this was my command: sudo apt-get remove python2.7. However, this removed Python 3.3, which came pre-installed. Thus, one by one the applications stopped working and I had to restart my computer. Now, I can log in to Ubuntu but nothing appears on the desktop. No dock, nothing. Not much of a problem, since I still have Windows 7 installed.

I also booted Ubuntu with advanced-options and then used the root to try to reinstall Python 3.3 (sudo apt-get install python3.3) but it said I have the latest version installed already.

However, I just checked using a partition manager (DiskInternals Linux Reader), and Python 3.3 is still there, at /usr/lib/python3.3. Could this be another problem then? If so, how can I fix it?

I don't want to reinstall Ubuntu because when I first installed it, it reset Windows (located on my C drive, my D drive remained unaffected) back to its defaults, and I had to reinstall all of my programs.

  • if you could provide us the list of pkg's uninstalled then more we can solve your issue. – rɑːdʒɑ Aug 5 '13 at 16:38

open your terminal with CTRL+ALT+T and type as

sudo apt-get install --reinstall python3.3 

that will fix your issue.

|improve this answer|||||
  • I can't access the terminal directly; like I said nothing shows up once I log in. I can use the root terminal by booting Ubuntu with advanced options... Would that work as well? – Rushy Panchal Aug 5 '13 at 16:35
  • 1
    I will update my answer with how to open terminal with KB – rɑːdʒɑ Aug 5 '13 at 16:37
  • I have tried that before, and it did not do anything. I just tried now, and still nothing happens when I tried Ctrl+Alt+T. – Rushy Panchal Aug 5 '13 at 16:42
  • yup! type ctrl+alt+f1 and then login there. then you can continue. – rɑːdʒɑ Aug 5 '13 at 16:43
  • 1
    seems to be Unity broken , now issue will be new. try this sudo apt-get install --reinstall ubuntu-desktop – rɑːdʒɑ Aug 5 '13 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.