I'm trying to set up a MacBook Air 6,2 to dual boot OSX and Ubuntu 12.04.

I've been following these instructions:


I'm using refit instead of refind because I saw some reports that refind wasn't working properly with MacBook Airs (and that refit worked fine).

I've gotten to the point of needing to resync the partition tables in refit. When I run the partition tool I see this:


Is this what it's supposed to look like?

I'm concerned that in my current GPT table the partition I formatted as EXT4 and set to mount at / is showing up as "basic data" and that in the "Proposed new MBR partition table" there is no linux. If this is not as it should be what might be the problem and how might I fix it?



"Syncing" partition tables is creating a hybrid MBR. Unfortunately, hybrid MBRs are ugly and dangerous. In your installation, they're also probably unnecessary -- if you boot Linux in EFI mode rather than in BIOS mode. Unfortunately, the last time I checked, Ubuntu favored BIOS-mode installations on Macs, but you can reconfigure the computer to boot Linux in EFI mode. Thus, I recommend you consider this option rather than use a BIOS-mode installation.

If you go ahead with a BIOS-mode installation, you may want to create a BIOS Boot Partition on the disk and then use either gdisk or the version of gptsync that comes with rEFInd to prepare your hybrid MBR. gdisk gives much better control than either version of gptsync over hybrid MBR creation, and rEFInd's gptsync is smarter about what partitions get included than is rEFIt's gptsync.

As to rEFInd and MacBook Airs, I'm rEFInd's maintainer, and I've received reports both ways on this score. (Unfortunately, I don't have one of the affected computers, which makes it very hard for me to fix the problem.) You might try preparing a USB flash drive image with rEFInd and test with it. If rEFInd works fine that way, then you should be fine with a regular hard disk installation. If it fails, try removing unnecessary drivers (from the EFI/BOOT/drivers_x64 directory on the flash drive) and try again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.