This question already has an answer here:

hope u can help me.

I have a Dell Inspiron N4030 and using on it the Ubuntu 13.04. This notebook has a BCM 4313 Broadcom wifi chipset, that is causing some headaches to me.

It connects but, after a couple minutes lost the connection with internet. Curiously it doesn't lost the wifi connection, only the internet connection (in other devices the internet keep active).

I've tried countless solutions that I found on the internet and nothing work =/

My kernel: 3.8.0-27-generic

I've tried with firmware-b43-installer and bcmwl-kernel-source and both give me the same problem. Using a USB wireless adapter I can surf normally.

marked as duplicate by Luis Alvarado Aug 10 '13 at 16:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • So you are using a nonofficial kernel? Have you installed firmware-b43-installer? – edwin Aug 5 '13 at 0:17
  • Are you using chroot or bootstrap?? I am still curious: why are you using kernel 3.10? – edwin Aug 6 '13 at 0:47
  • Do you have this problem while using a wired interface (Ethernet)? – edwin Aug 6 '13 at 1:08
  • Ok, but please add this to your question by editing it, then remove the comments. That way we keep things tidy :) – edwin Aug 6 '13 at 1:23
  • did you install b43-fwcutter? I have two dell laptops with broadcom wireless cards and both required that to be installed. – Bryan Aug 6 '13 at 3:54

If you have not installed any other drivers but the sta driver this should get your wireless working. In 13.04 the brcmsmac driver finally started working better with this device then the sta driver.

sudo apt-get purge bcmwl-kernel-source

sudo modprobe brcmsmac

Not the answer you're looking for? Browse other questions tagged or ask your own question.