I've tried to install Ubuntu on my Nexus 7 3G. I used this link. My tablet won't boot with Ubuntu, and I've received in the recovery mod this error message:

Checking for autodeploy.zip
autodeploy.zip not found.

I've used these commands to do it manually:

adb push ./saucy-preinstalled-touch-armel+grouper.zip /sdcard/autodeploy.zip
adb push ./saucy-preinstalled-touch-armhf.zip /sdcard/autodeploy.zip

...but it didn't help.

Tell me please, what can I do to install Ubuntu?

  • Could you provide ls -l /sdcard/? – Braiam Aug 4 '13 at 5:22
  • ~ # ls -l sdcard lrwxrwxrwx 1 root root 11 Aug 4 05:33 sdcard -> /data/media – AlexUKhitev Aug 4 '13 at 5:34

The 'Manual Installation' instructions appear to be incomplete (for a full install).

The two files are used to 'update' an existing install. A 'full install' has 3-4 more steps.

Specific to ASUS Nexus 7 3G

The Nexus 7 3G model is not yet supported, but can use the standard Nexus 7 ('grouper') build.

The tag -d grouper needs to be present.

Try using the provided tool, as described on the Wiki.

phablet-flash -d grouper -b (full install, current) or

phablet-flash -d grouper -b --pending (full install, untested daily)

From there, you can probably create the extra manual steps.

To download ALL files first (without a device attached) use:

phablet-flash -d grouper -b -D (current)

phablet-flash -d grouper -b -D --pending (untested daily)

UPDATE: (23-Aug-2013)

The ASUS Nexus 7 3G (and in particular the 32 GB model) are somewhat different from the base model of the Nexus 7 ('grouper'). They have support for GSM 3G/4G and other low-level firmware changes.

Before Ubuntu Touch was 'flipped' (still ran Ubuntu in a container inside Android), this did not provide an insurmountable problem. However, the additional features not found in grouper were also not available.

Now with the 'flipped' design, and with current changes to the underlying Ubuntu Touch OS and UI, only the base model Nexus 7 (grouper) is currently supported.

See also:

Latest two images will not install on Nexus7 (32GB + 3G), but older were Ok

The latest two (newest) daily images will not install on my Nexus 7, 32GB + 3G. The older versions work fine. Background looks like coloured snow. ..

Nexus 7 3G [2012] problem with ubuntu touch

Nexus 7 3G is not equivalent to grouper.

Nexus 7 is a commercial name that hides a lot of different hardware configurations in it.

If the hardware codename is tilapia [2012, 3G] or razor [2013] the device will not work without modifications or what people call ports, please refer to https://wiki.ubuntu.com/Touch/Devices

and more technical:


Ubuntu uninstallable on 32GB 3G Nexus 7

Nexus7 variants without 3G support map their user data partition (UDA) to mmcblk0p9, where variants with 3G support map UDA to mmcblk0p10 ..

  • 1
    I've tried phablet-flash -d grouper -b, but it didn't help. The device does not boot further label Google. At recovery mod, I see: "autodeploy.zip not found". After pushing saucy-preinstalled-touch-armel+grouper.zip by adb push, I select install zip from sdcard. I've checked this file $ adb shell ~ # ls /sdcard autodeploy.zip After this, I recieve: Finding update package... Opening update package... Installing update... Install from sdcard complete But after adb reboot, I see only Google label. What I did wrong? – AlexUKhitev Aug 4 '13 at 7:37
  • 2
    same problem with me.no answer from anyone. – Ubuntuser Aug 22 '13 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.