3

I installed a new drive today in my old computer. I'm running Windows 8 and Ubuntu 13.04 using BURG as my bootloader. On my old drive grub/burg would load up instantly. However, now that I've replaced my old one with the new one, the computer just sits at the BIOS screen for about 30 seconds, and then "grub loading" comes up and I'm good. Googling "grub takes 30 seconds to load" brought up a bunch of other threads, but their problem was slightly different. In their problems they said that the computer sat at "grub loading" for 30 seconds. However, mine doesn't even show "grub loading" until the end of the 30 seconds. I'm not sure if this is a problem with grub or a problem with my bios/new drive. Furthermore, if I press f12 to go into the boot menu, and choose my hard drive manually there, grub loads up immediately. This is strange cause grub always loaded up immediately on my old drive.

1

If the delay occurs before grub screen (or burg, doesn't make any difference) it's not a grub problem. Check your bios configuration, maybe your system is trying to boot from the old hardrive but since you added a new one, it spends 30 seconds looking for a media to boot that is not there anymore. Try to change the boot up sequence in the bios (can't help you about how to because that depends on the motherboard problem, but usually you can acces to the bios setup trough F2, F8, F10 or the DEL key before grub jumps in. Set the new hardrive as primary boot media.

Good luck!

1

1) Reduce the default grub load time:

you can simply use the following command to open grub configuration:

sudo gedit /etc/default/grub &

And change GRUB_TIMEOUT=10 to GRUB_TIMEOUT=2. This will change the boot time to 2 seconds. Prefer not to put 0 here as you will lost the privilege to change between OS and recovery options. Once you have changed the grub configuration, use the following command to make the change count:

sudo update-grub

2) Speed Up Ubuntu Booting Time via Grub (Source = Ubuntubuzz)

here's to do it, open your grub configuration file (/etc/default/grub) and find this line GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”, do as follows :

sudo gedit /etc/default/grub

replace

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

with

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash profile”

save and exit

sudo update-grub2

sudo reboot

Grub does a search for all the necessary drivers to load, Instead of making Grub search for required drivers, the profiling actually makes Grub remember every necessary driver to work, This action will cutting down all of the driver load times.

after your system up, edit /etc/default/grub and remove some option which we have added before.

sudo gedit /etc/default/grub

replace

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash profile”

with

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

save and exit

sudo update-grub2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.