This is a common problem with Ubuntu. If I open the command line, something pops up really fast that says the BIOS disabled something. It let me login on the command line. I tried a bunch of commands that I thought would have opened or updated my bios. Nothing worked. Is there a way I can get my display working again through the command line?

  • It said kmv: disabled by bios – John Aug 3 '13 at 1:22
  • 1
    You mean KVM :disabled by bios right?? – Stormvirux Aug 3 '13 at 2:14
  • The message about KVM disabled may have nothing to do with your problem. Please re-describe your problem. Are getting a black-screen (with just cursor top right), when you want to see the GUI (graphic interface)? – david6 Aug 3 '13 at 2:30

Have you considered looking into your BIOS settings? There is usually an "Intel VT" or "Virtualization" option that isn't enabled by default. This is being modified. If you are unable to modify it in the Bios Try the following

First of all, you might want to see if KVM is loaded in the kernel. To do this, run something like this:

lsmod | grep kvm

If you do get any answer from that, you may want to stop kvm from running. To do that, this will help:

modprobe -r kvm

Remember to follow for any other kvm module. In my case, there is also a kvm_intel module, so I also have to run modprobe -r kvm_inteland modprobe -r kvm_amd.

To stop kvm from being enabled at boot time you have to find the file located at /etc/modules and modify it so that KVM doesn't launch at boot time. After you modify your /etc/modules file restart your computer and see if the problem persists.

I would recommend checking out the following:

If you do not use VMware you can run the following(It breaks VMWare)

sudo apt-get purge kvm

If you want to still continue using quemu with KVM look for a more recent BIOS on the vendor's web site.


  • On some hardware (e-g HP nx6320), you need to power-off/power-on the machine after enabling virtualization in the BIOS.

  • Enabling some BIOS features may break VT support on some hardware (e-g Enabling Intel AMT on a Thinkpad T500 will prevent kvm-intel from loading with "disabled by bios")

  • On some Dell hardware, you also need to disable "Trusted Execution", otherwise VT will not be enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.