3

I've installed the TrueType version of the Lucida Grande font from my Mac. It seems to show up fine when setting desktop options for screen, system, document, menu, titlebar, etc.

However, it will not show up in the font list in LibreOffice for anything.

I've rebuilt the font cache several times. Any other font works for both just fine, just not this one.

Any ideas as to what would cause this?

  • Have you restarted LibreOffice? (If you have the quickstarter running, you need to exit that too). – RolandiXor Mar 31 '11 at 3:00
  • Many times. And rebooted the system. I installed the fonts about 3 months ago, maybe more, I don't recall. Something else is amiss. – user13314 Apr 1 '11 at 0:40
1

Assuming the font was place in one of the folders the font cache looks in, i.e. ~/.fonts, the only thing I can suggest is a reboot. That may be required for LibreOffice to recognize the updated font cache.

  • I thought the font cache looked in /usr/share/fonts no? I'll copy it to ~./fonts and see what happens. Otherwise, I've rebooted several times with no change. – user13314 Apr 1 '11 at 0:39
1

Proportional True Type fonts are turned off by default

Go to Tools -> Options -> Fonts where you will see:

Libreoffice Non-Proportional Fonts.png

Remove the check mark beside Non-proportional fonts only then click OK button. Now many more fonts will available for you including the ones you just installed that were missing.


Permissions are important

Ensure your font directory has the correct permissions:

sudo chmod 755 /usr/share/fonts/truetype/<font_dir>

Ensure files in the font directory have the correct permissions:

sudo chmod 644 /usr/share/fonts/truetype/<font_dir>/*

Source: [Solved] Barcode Fonts on Linux not visible

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.