gang. I am in a bit of a pickle.

I can only boot into GRUB RESCUE, even if I attempt to boot from a USB stick. And:

All the commands I have tried in GRUB RESCUE (i.e. "help" "halt" "reboot" "insmod" "sudo") only yield the repsonse "Unknown command 'xxxx'"

However, inputting "ls" does yield "(hd0) (hd0,msdos1)" etc.

I was dual-booting Xubuntu and Windows 7; this happened after I formatted the Windows 7 partition using Parted Magic to ntfs.

So, to recap: I can't (as far as I can tell) boot from USB; any attempt to boot lands me in GRUB RESCUE (or BIOS). No commands I have tried work in GRUB RESCUE.


Thanks. :)


Changing partitions may have reordered them. But UUID should be the same. If you did not delete or the partition tool did not delete the Linux partition, you should be able to use Boot-Repair to fix the grub install. But if partition is missing you need testdisk from liveCD.

Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.: https://help.ubuntu.com/community/Boot-Repair You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems. LighterWeight (Lubuntu based) Boot-RepairCD http://sourceforge.net/projects/boot-repair-cd/files/



  • 1
    Thank you very much for your thorough assistance. Though I initially couldn't get any of your suggestions to boot of a USB either, I, by a complete guess, found out how I could: I had Boot from USB enabled in BIOS and placed above the hard drive in the boot order, but when I DISABLED booting form the hard drive, all became peaches. Thanks again! – user165793 Aug 2 '13 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.