When I use skype my video is upside down. But when I use Google hangouts or cheese it is fine. How do I fix this?

I have tried many things and nothing ever has worked. My laptop is a Asus K53E.


This is a link to a blog that appears to have solved the upside-down webcam issue on ubuntu 12.10.

First you need to make you have the libv4l-0 package installed.

To install libv4l-0 open a terminal and type:

sudo apt-get install libv4l-0

If your system is 64-bit then you should specify the i386 architecture, as this is what seems to work with Skype:

sudo apt-get install libv4l-0:i386

Step 2 is to edit skype.desktop so you can pre-load libv4l-0 with skype so type in terminal: sudo gedit /usr/share/applications/skype.desktop

In this file find Exec=skype and replace it with with Exec=env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

  • 1
    If your system is 64-bit you should sudo apt-get install libv4l-0:i386 instead. – Tamer Shlash Nov 7 '14 at 5:41
  • For my 64bit 14.04 machine what worked was Exec=env PULSE_LATENCY_MSEC=60 LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype %U The original line looked like Exec=env PULSE_LATENCY_MSEC=60 skype %U . Now the problem is that Webrtc tools for me show upside down: so definately a problem with drivers, not skype. So this should be taken as a patch not a fix. – Andres Dec 8 '16 at 12:51
  • Since, the Skype version 8 and above is basically a web app, the trick with libv4l will no longer work. I've lost many hours to just find out it's not possible now. So my solution was extremely straightforward: I've just bought an external web camera... and it works flawlessly. Moreover: I finally realized built-in camera in Asus K-series was extremely low quality. The external one is sooo much better. – G. Demecki Jun 16 '18 at 16:30

On Ubuntu 14.04 LTS, this fix does not work with my Asus PC. The output of above command is:

$ LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

Eventually, I got the command working from the README.doc in /usr/share/doc It was:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so skype

With an installation of the package:

sudo apt-get install libv4l-0:i386

Happy :-)

  • You really shouldn't ask question within answers. Please delete those parts and only keep the things that help other users to resolve the same problem. – MadMike Oct 22 '14 at 11:35

protected by Community Nov 20 '14 at 12:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.