13

On Ubuntu 12.04 LTS on a Dell Vostro 2420 laptop, each time I start Ubuntu, the screen brightness is set to the maximum level, which gives a high glare. (I have recently installed Ubuntu on the laptop, but did not change any default settings related to brightness, IIRC.) I am currently lowering the brightness manually each time after starting, using the System Settings icon on the left of the screen. Looking for a permanent way to set it to a lower value.

12

After you set the brightness to your desired level open up a terminal and check what the brightness is set to by using

cat /sys/class/backlight/acpi_video0/brightness

Then you can take that value and

sudo gedit /etc/rc.local

Right above exit 0 add

echo your_value_here > /sys/class/backlight/acpi_video0/brightness

and then save the file. This will permanently set the brightness to your value as rc.local is executed at each reboot.

Note: This only works if you have a file named brightness in /sys/class/backlight/acpi_video0/

6
  • Thanks, have made that change. Not rebooted to test it yet. Will do so shortly and then reply here whether it worked. Pretty sure it will, since I saw the value in the file change even when I changed the brightness via System Settings. – TooBrightScreen Jul 31 '13 at 17:11
  • I rebooted, and the changes have taken effect. Thanks! – TooBrightScreen Jul 31 '13 at 18:13
  • @TooBrightScreen Glad it worked, please feel free to mark it as answered so others could easily find the solution. – bigbash Jul 31 '13 at 18:16
  • How to mark it as answered? I looked in most places in this screen, also hovered mouse over most of the icons, but don't see any way to mark it as answered. Do I need to be above some value for reputation to mark it? – TooBrightScreen Jul 31 '13 at 18:32
  • @TooBrightScreen What should I do when someone answers my question? – bigbash Jul 31 '13 at 18:36
2

Install backlight on your system.

Place the command xbacklight -set value in your startup.

It will automatically do the job for you. Hope this helps!

1
  • You mean install xbacklight? – Lucas Farias Jun 24 '17 at 23:57
0

@bigbash after setting the brightness to a desired set value i am typing this command, /sys/class/backlight/acpi_video0/brightness, did the way u have suggested but it is not working.One more thing what ever value i set for brightness from settings after putting the above command always i am getting the same value i.e 15.

1
  • That means you have more than one display output. Or at least, you did plug at least one before. Try looking at /sys/class/backlight/acpi_video1/brightness. I hope this helps. – user1652575 Nov 5 '14 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.