3

I'm trying to update my version of Catfish search, which is currently 0.6.4 and I'm trying to get 0.7. I installed 0.7 and it said it was installed in software centre, but when I click the shortcut, I get served 0.6.4.

So I uninstalled catfish from the software centre - now it says 0.7 is available to install (so I must have done the software source / PPA bit right), but the icon is still in the shortcut menu & when I click it:

Catfish (0.6.4) is still there.

So I did "sudo apt-get remove catfish" and it says "not installed so not removed". Yet if i type "catfish", up it pops, instantly. I did some googling, did "sudo apt-get remove catfish --purge" which removed one file.

Catfish is still there.

Since I installed 0.6.4 and previously 0.6.3 from zip files and those files are all in my home folder, I deleted all those files.

Catfish is still there.

Can anyone specular as to what's going on?! Thanks.

  • Issue these 2 commands in terminal sudo updatedb and locate -i catfish . The results will help you to locate any relevant file of catfish still on your OS. Also you can edit your question and add the results of above commands. – NickTux Jul 31 '13 at 15:29
2

One option would be to go to the folder you installed it from (where the Makefile resides - pretty much where you unzipped it to in the first place, and where you navigated for the initial make install command) and typing sudo make uninstall. Generally speaking this will remove the files that were copied to various places during the installation process (if it's appearing in your Dash then it's unlikely to have only put files into the home folder)

The reason the apt-get commands aren't working for you is that you installed from a zip file - apt-get only controls packages downloaded from the repositories, so you can only apt-get remove or apt-get purge packages you apt-get installed in the first place.

  • hmm... so if i've already deleted those files/folders, will unzipping them to the same place and doing 'sudo make clean' work, do you think, or will i need to reinstall 0.6.4? (I just unpacked the zip to the same place and tried it and got "make: *** No rule to make target `clean'. Stop.") Also tried ./configure then the clean, clean worked but many files still present and catfish still works... – dez93_2000 Jul 31 '13 at 19:35
  • I may have been mistaken. make clean apparently targets intermediate files, not things that have been installed. So, what you actually need to do is ./configure and then make uninstall - this should, as long as the target has stayed the same as when you installed, remove all the files, but not guaranteed. – Jez W Aug 1 '13 at 9:21
  • Jez old chap, you are indeed the boss. CHEERS! – dez93_2000 Aug 1 '13 at 13:54
  • Great, glad to hear it worked! (and you're the second person this week to say that. It's good to be the boss ;)) – Jez W Aug 1 '13 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.