14

Anyone knows how to do it? It doesn't inherits openbox's settings so i tried advices, related to other unity/gnome (maybe chrom* inherits it):

$ gconftool-2 --get /apps/metacity/general/button_layout
close,minimize,maximize:
$ gsettings get org.gnome.desktop.wm.preferences button-layout
'close,minimize,maximize:'
$ gsettings get org.gnome.shell.overrides button-layout
No such schema 'org.gnome.shell.overrides'

But buttons still on the right side. And I still don't want additional useless native decorator.

26

Looks like you have not enabled setting "Use System Title-bar and Borders".

Go to Settings in Chrome/Chromium > Search for this option and check-mark it.

Chrome Settings

Update

While above solution will use native window frame, if you want to avoid using that, you can have a look at this answer. If it still doesn't solve the problem, I believe it is something to do with OpenBox which doesn't use Metacity decorator.

| improve this answer | |
  • 1
    I wrote 'And I still don't want additional useless native decorator.'. It means i wanna use chrom* without native decorator. So don't advice me to turn it on :) – actionless Jul 31 '13 at 9:31
  • It takes about 1 cm of additional vertical space. – actionless Jul 31 '13 at 9:32
  • @actionless: Totally missed out on that, updated my answer. – Kushal Jul 31 '13 at 9:37
  • in question i copied gconf/gsettings output -- it looks like in it in answer you referencing to -- so i have no idea, from which system settings chrom* gets these settings. – actionless Jul 31 '13 at 9:45
  • Btw, ubuntu doesn't use metacity too. So it very strange, why changing metacity settings helps chrom* in unity, but doesn't helps in openbox. But whatever thank you for trying to assist. – actionless Jul 31 '13 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.