6

How can I enable usbfs in Ubuntu 13.04? I could not find the usb/devices file in default path, which is:

/proc/bus/usb/devices
10

Not available in the current versions of Ubuntu

Usbfs has been deprecated for a long time already. It was disabled since Ubuntu 9.10 (but you could recompile the kernel to get it -- CONFIG_USB_DEVICEFS=y). In the Linux kernel it was completely removed in 3.5 so it is completely missing since Ubuntu 12.10.

So the bad news is that you cannot enable usbfs in Ubuntu 13.04 if you do not replace the kernel for an older or patched one.

Alternate solution

It seems that the similar content as was in /proc/bus/usb/devices is now available in /sys/kernel/debug/usb/devices. Other interesting places to check for the content from former usbfs are: /dev/bus/usb, /sys/bus/usb and /sys/kernel/debug/usb.

See also for example Where is usb/devices file in Ubuntu 9.10?

3

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo mount -t usbfs none /proc/bus/usb -o devmode=0666
  • 2
    Since Ubuntu 9.10 the mount point /proc/bus/usb does not exist because usbfs is not enabled in the kernel. Since Linux kernel 3.5 (Ubuntu 12.10) usbfs is missing completely. – pabouk Dec 8 '13 at 21:55
  • 1
    mount: mount point /proc/bus/usb does not exist – Tom Hale Jan 25 '17 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.