The issue:

When I open the "add new project" dialog (screenshot below), I can't create a new project. The loading message (hourglass icon) stays on forever. Except for "cancel", the other buttons are disabled.

It was working fine a few days ago, I haven't changed any setting prior to the issue appearing. I ran the internal update feature, but the issue persists.

enter image description here

The info:

My OS version: Ubuntu 12.04.2 LTS 64 bits

Netbeans version:

Help -> about

Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.6.0_27; OpenJDK 64-Bit Server VM 20.0-b12
System: Linux version 3.2.0-49-generic running on amd64; UTF-8; pt_BR (nb)
User directory: /home/user/.netbeans/7.2.1
Cache directory: /home/user/.cache/netbeans/7.2.1

What I tried:

  • Changing the Look and Feel with the --laf command-line option. The look-and-feel does change, but the issue persists.
  • Using the internal update command, a plugin got updated but the issue persists.
  • Downloading and installing the latest version (7.31), it imported the settings from the previous version and the issue persists.
  • Removing the settings folder ~/.netbeans/7.3.1, restarting netbeans, choosing not to import settings and rather have a new clean install

Just posted the same question here ... the solution for me was to downgrade OpenJDK from 6b27 to 6b24 (look at the link for details).

My NetBeans was looking excactly like in your sreenshot and also had some other strange problems.

I would suggest you do java -version if this shows that you have 6b27 installed and cat /var/log/dpkg.log | grep openjdk shows that you recently received the OpenJDK update you can try to fix the problem reverting to 6b24 using this command:

apt-get install openjdk-6-jre=6b24-1.11.1-4ubuntu2 openjdk-6-jre-headless=6b24-1.11.1-4ubuntu2 icedtea-6-jre-cacao=6b24-1.11.1-4ubuntu2


As I discovered some other problems (SSH connection wouldn't establish within NetBeans) I finally took the step to upgrade to Oracle JDK7. To start NetBeans with another JDK you have got to edit ./netbeans-7.X/etc/netbeans.conf and change the line netbeans_jdkhome="/usr/lib/jvm/java-7-oracle/jre" (I guess this gets generated in the NetBeans installation process). Otherwise it will still use your old JDK no matter what java -version says.

  • 2
    Good suggestion! You may also want to try Java 7, since JDK 7 and the OpenJDK equivalent have been released for quite a long time now, so there's really no reason to stick with Java 6.x. Jul 31 '13 at 13:59
  • @somequixotic I updated to it on my notebook, but for some reason the problems with NetBeans weren't gone. Perhaps it was still using OpenJDK under the hood? java -version showed java version "1.7.0_25" Java(TM) SE Runtime Environment (build 1.7.0_25-b15) Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)
    – s1lv3r
    Jul 31 '13 at 14:29
  • Aha! dpkg.log shows upgrade openjdk-6-jre-lib 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2 and two similar others on July 24th, one day before I left on a short vacation, nad Netbeans was working. Might be the culprit! Jul 31 '13 at 18:47
  • 1
    @ruda.almeida The downgrade solved the problem with the new projects for me, but later one I had other problems (with SSH), so the real final solution for me was to install openjdk-7-jre (or the oracle version - both work) and change the path in the netbeans.conf.
    – s1lv3r
    Jul 31 '13 at 22:34
  • 1
    Just in case: For me works installing "sudo apt-get install openjdk-7-jre", but the with path in config file as: netbeans_jdkhome="/usr/lib/jvm/java-7-openjdk-amd64/jre", instead of the one you put in your answer
    – leticia
    Aug 1 '13 at 19:54

It's a bug caused by the JDK version used:

This problem is JDK bug with focus (never ending loop when requesting focus). Issue filed against JDK is http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6598089. (IcedTea and in future OpenJDK will be distributed as default JDK for Linux distribution so it should be supported.)

The bug seems to affect both Oracle JDK and OpenJDK. Update your JDK in order to fix it. (Don't forget to chante the netbeans_jdkhome variable in the ./netbeans-7.X/etc/netbeans.conf file!)


Try changing your Netbeans' Swing Look and Feel to Nimbus.

  • Tried Nimbus, Metal, GTK, etc. The look and feel changes, but the unclickable buttons and eternal loading persists. Jul 30 '13 at 15:44
  • what version of Netbeans? anything on the console when you run netbeans from the console? Jul 30 '13 at 15:46
  • Nothing on the console if started from the command line. Jul 30 '13 at 16:29
  • do you have any important projects prior to this lock up?
    – mojo706
    Jul 30 '13 at 16:50
  • @mojo706 No, and the ones I had are backed-up Jul 30 '13 at 17:16

I had the same issue last night one Ubuntu 13.04

I have openjdk 6 installed and the install was successful but netbeans hung when I tried to create a new project.

Today I managed to solve it after screaming at my computer and scaring my girlfriend :)

Pretty sure this solved it.

Go to https://netbeans.org/community/releases/73/install.html#install_windows and you'll see that you need to chmod the installer:

chmod +x installer-file-name

before you install...

sh installer-file-name

Once I did this I got an executable netbeans on my desktop (for some reason not listed in applications).

One thing to note about the installer, for me it said it couldn't get access to some JUNIT packages, i selected 'quit these modules' or something similar, and the rest of the installation worked fine.

I hope this solves your issue too!

  • I had to chmod +x the installer or it wouldn't even install the new version. That's not the cause of my issue. Jul 31 '13 at 12:52
  • @Ruda, the only other thing I did differently was installing netbeans prior to any other updates (ie I reinstalled ubuntu, and only installed the jdks (6 and 7) before installing netbeans). Other things to try: Run the installer with jdk7 and 6 and see if anything happens differently between them. Sorry my answer didn't help.
    – planty182
    Jul 31 '13 at 13:36

I've been having this problem for a couple of days and it's been totally winding me up.

Just resolved it however by changing my version of Java from OpenJDK to Oracle

These might help you -



  • ... forgot to mention, then either have to reinstall netbeans or update netbeans.conf to use new jre
    – user180187
    Jul 31 '13 at 15:59
  • It looks like a valid answer to me.
    – Pilot6
    Jun 14 '16 at 11:52

I solved it by upgrading to open-jdk 7.


I had run in to the same problem and a few others trying to get Netbeans to work on 12.04LTS, this is how I managed to have a full working copy.

I (please don't shot me) used a windows device to download the full Netbeans package from the Netbeans website.

I then transferred the .sh file to my desktop, then I needed to change the permissions to allow the file to be executed, with;

sudo chmod +x netbeans-7.4-linux.sh

then I simply installed the file with;


Netbeans does not show up in applications but there is a launcher on the desktop.

Hope this is of some help to someone :)


For me changing




in the netbeans.conf file worked. :) :)

  • 1
    This answer is incomplete as it stands, It will only work if you already have Java 7 installed, if you are using openJDK, if your processor architecture is amd64, etc. Nov 18 '13 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.