I am trying to install smbfs on my ubuntu 12.10, and face the following problem. I have tried uninstalling and resinstalling samba, still same errors.

$ sudo apt-get install smbfs 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 smbfs : Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3) but 2:3.6.6-3ubuntu5 is to be installed
E: Unable to correct problems, you have held broken packages.

Please help.


According to this page https://wiki.ubuntu.com/MountWindowsSharesPermanently

It seems smbfs is deprecated and you should use cifs instead. try :

sudo apt-get install cifs-utils
  • i tried, it says cifs-utils is already installed and latest version.
    – shivshnkr
    Jul 31 '13 at 2:54
  • @shivshnkr cifs-utils replaces smbfs, hence you don't need smbfs but cifs-utils. The output is correct, nothing has to be done.
    – Braiam
    Aug 14 '13 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.