As the title would suggest, I am having trouble booting from my new SSD that I installed in my ASUS R500V K55VD today. I have been running Ubuntu on the HDD since I got the laptop, but I wanted to upgrade to an SSD. I installed the SSD in a caddy that slots in to where the DVD drive was.

When entering the BIOS I can see that SATA is in AHCI mode and that my SSD and HDD are both being discovered, however I cannot see a boot option for the SSD; only the HDD has an option. I cannot see a way to add my SSD to the boot list.

Booting in to the Ubuntu 13.04 live USB I can see that the OS installed itself on my SSD, but I simply cannot get the BIOS to boot from it. Has anyone else had any problems using two storage devices on this laptop that can shed any light on this?

I also tried using the suggestions in this question, but I still end up at the grub rescue prompt :( I have the following layout:

HDD (sda):

  • 512MB /boot
  • rest /media/data

SSD (sdb):

  • All /

I have tried installing the bootloader in the /boot partition and just directly in sda with no observable difference.


Answering my own question since this problem is now solved.

I managed to solve my problem by formatting both drives and creating new partition tables as the problem was the GPT. Creating the /boot partition on the HDD and placing / on the SSD solved my problems as per the linked question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.