I have an older desktop computer with two hard drives that do not have the /dev/sda format so from my research I see, I'm dealing with a fakeraid or RAID setup. I have run the Ubuntu 13.04 installation several times and so far nothing has worked. It always stops and gives me a fatal error that: Grub cannot be installed on /dev/sda. I have tried many options to install grub using the livecd, but nothing is working.

  • Look into /dev/mapper directory. The device node without number may be the disk you need. Consider to check this in Palimpsest. – Danatela Jul 30 '13 at 5:21

If you're only intending to use one partition, you can try removing the existing raid setup, and reinitializing it through Ubuntu. I have a lot of trouble with my "fake raid" in Ubuntu as well.

Did you set your Raid up through the BIOS? I would try removing that, and letting the Ubuntu installer set up it's own raid partition.

Note: The installer can set up some good fake raids that automount at boot and all that fun stuff, but from my experience, other OS don't detect the raid, ie. Windows dual boot wouldn't detect the RAID partition, just the two hard drives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.