I tried installing Ubuntu 12.04 using Wubi and it just doesn't work, every time, without fail. I had the following scenarios:

1. I downloaded only wubi.exe and ran it.  
The wubi installer started downloading the amd64.iso using torrent. But when there were just about 40 secs left to download, it shows an error 404: File not found.    

2. I downloaded the iso file seperately and put it in the same folder as the wubi.exe. Now there are two cases:  

  a. Offline: wubi says it could not download the metalinks file and hence cannot download the iso.
So I download the meta files separately and place them in the same directory. wubi shows the same error again. 

  b. Online: wubi works in same way as in case 1. and the same problem occurs as in case 1.  
In short wubi doesn't recognize the already downloaded iso in the directory at all.  

3. I burn the iso into a Cd and run it. The same thing occurs as in Case 2.

Just in case that you know, I installed SP3 for win XP just before using wubi. While Windows is running alright, is it possible that its causing conflicts for wubi?

  • First do you have xp 64bit? if so, have you downloaded 64bit ISO? If no then ubuntu tries to download 64bit ISO. To use 32bit ISO, you need to run wubi with --32bit parameter. More details – Web-E Jul 29 '13 at 11:59
  • No my xp is 32 bit. But I think that my cpu can run 64 bit.(because I ran the 64 bit version of anaconda- The fedora installer- and it ran just fine) Also wubi automatically tries to download the amd64 version. So I thought that this must be the correct iso. – Quirk Jul 29 '13 at 12:03
  • No default download from ubuntu site is 32bit. Did you explicitly changed the download option? try with 32bit argument as in the instruction of that page. – Web-E Jul 29 '13 at 12:07
  • @Web-E No the ubuntu page doesn't allow explicit installers for wubi acc. to system architectures. However if my system is capable of 64 bit then I want to install 64 bit ubuntu. However I think, I'll try your suggestion. BTW do u think that I should try the "avoid md5 sum check" option. Maybe then it will not download the meta files? – Quirk Jul 29 '13 at 12:16
  • No I was talking about the ISO you downloaded.. it must be 64 bit .. by default ubuntu provide 32 bit ISO. IF 32bit ISO, you need to run wubi.exe with --32bit argument – Web-E Jul 29 '13 at 12:22

I also have 12.04 alongside Ubuntu in my Windows XP, and I've also encountered same errors while trying to use Wubi

I guess that wubi failed in locating the .iso installation file. In my case, I paste the Ubuntu iso in the Windows root directory (C:), open the iso without extracting using winrar, and double click the wubi.exe inside, and everything goes well.

  • I tried doing the same thing as above except I put the ISO in another drive except the root Windows drive. But the same error occurred. But I tried this with a program similar to Wubi for Linux Mint called Mint4Win and it ran fine. Dunno what's the problem. Using Mint for now. – Quirk Nov 5 '13 at 16:34
  • Try to put the ISO in the root Windows drive, just checking if it works – Jake Nov 7 '13 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.