2

So, yesterday I installed Ubuntu on my laptop (1920x1200), which I mainly use docked with a second monitor (ViewSonic VA720, VGA, 1280x1024). At first the second monitor wasn't detected at all, so I installed the Nvidia-313 driver (I am currently running the Nvidia-310 driver, figured I'd see if it made a difference; it did not.) Well, the monitor is now detected, however the native resolution is not an option. It only allows the display to work in 1024x768.

I've tried creating a new mode in the terminal under 'xrandr', however when I try adding the mode to my monitor (VGA-0) the output is:

X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 31 Current serial number in output stream: 32

I've tried editing my resolution in 'Nvidia Xserver Settings', however when I set the 'ViewportIn' and 'Panning' to their proper values it won't allow me to change the value of 'ViewportOut'. I then end up with this.

  • My GPU is the Nvidia Quadro FX 770M; any more information that would help will happily be provided, just ask.

Iechyd Da!

1

It depends on what your /var/log/Xorg.0.log is outputting. In some cases it could be due to the fact that the EDID is not being detected properly. Tragically, it means you have to do some fancy footwork to make this work properly.

In previous attempts I also tried setting the xrandr to not avail. Then I discovered this little tip (http://ubuntuforums.org/archive/index.php/t-1470168.html)

Research:

  • Go to the monitors website and determine the proper horizontal and vertical refresh ranges.

Modifications:

  1. Edit your xorg.conf - sudo nano /etc/X11/xorg.conf
  2. Within the Monitor section (see below) add your new ranges

Section "Monitor"

Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "CRT-0"
HorizSync      LowValue - HighValue
VertRefresh    LowValue - Highvalue
Option         "DPMS"

EndSection

Note: You do need the dash between. Also it's recommended that you add a # in front of the old lines so you have a copy that you can undo if all else fails.

Reboot your machine

1
  • I will give that a try - my second screen works but isn't recognized and henceforth a proper res and ratio are no options. So I would like to try to force it to use a specific res and ratio. My Windows 8 setup also doesn't recognize the screen but I can choose between a wider range of resolutions. askubuntu.com/questions/449753/…
    – Raffael
    Apr 20 '14 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.