3

I am trying to get my display working at 1080p instead of 1080i, I have no problem with this on my xbox or in windows 7 and I can sort of put together a solution that is already on this website. I am using a 23" 1080p HDTV as my monitor and my graphics card is a ATI Radeon HD 6850. I am currently using the xorg drivers for it but from what I have tried it does not work in the proprietary drivers either.

I am aware that this question has already been answered here: no 1080p@60hz option with nvidia card, but there is one problem that I am having with the fix, it is that the file path to the xorg.conf file must have been moved as when I try to open it, it creates a new document. I would be thankful for the knowledge of where this file is or if I have to edit anything different.

Thanks in advance, Jack

  • The location in the other question is where the file goes. They're trying to get away from using and xorg.conf file at all, and just have the system know out of the box the best way to handle your hardware. You can still make a new one and put it here to override default behavior. If you need a template, there's one in usr/share or you can generate one with Xorg :Z -configure where :Z is the display number. – RobotHumans Jul 28 '13 at 23:23
  • Hi hbdgaf, thank you for the help but I am experiencing one problem. When I execute the code to generate a template I am met with this message: Fatal server error: "Fatal server error: Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. (EE) Please consult the The X.Org Foundation support at wiki.x.org for help. (EE)". Also I am unable to find the file in usr/share. – Jack Jul 30 '13 at 9:01
  • Then kill X or use :1 instead of :0 – RobotHumans Jul 30 '13 at 19:54
  • So is it 1080i instead of 1080p, or opposite? Either title or question is misleading. – Andrejs Cainikovs Aug 15 '14 at 8:18
4

My case may not be similar to yours but I post my solution here hoping it helps other people. I ran:

xrandr --verbose

I was not able to change the mode to 1080p using xrandr "--mode 1920x1080 --rate 60" because it has two flavors, 1080p and 1080i, and 1080i is by default stupidly preferred.

DFP5 connected 1920x1080+1920+0 (0xa1) normal (normal left inverted right x axis y axis) 2210mm x 1250mm
    (...)
    CRTC:       1
    (...)
  1920x1080 (0xa1) 74.250MHz +HSync +VSync Interlace +preferred *current
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.75KHz
        v: height 1080 start 1085 end 1095 total 1125           clock  60.00Hz
  1920x1080 (0xa2) 148.500MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz

That's why I used --verbose option, it gives this special output where +Interlace (1080i) detail appears and especially the XID code in parenthesis: that's the key to force the mode.

xrandr --output DFP5 --mode 0xa2 --crtc 1 --verbose

As always, using the documentation helped:

man xrandr
| improve this answer | |
  • This was very useful thanks! Just to add my xrandr --verbose output had 2 very close selections, 59.94Hz and 60.00Hz and the one I needed (60) wasn't grouped together with others, it was listed on top of the 4k resolutions, so make sure to look through the whole list and choose 60Hz. – Beebee Apr 10 '19 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.