8

Whenever I search for something in KDE's Kickoff Application launcher, it also search in my browser history (both Firefox and Chromium).

I already disabled Nepomuk and selected "do not remember" under System Settings - Activities - Privacy. But it still shows my browser history.

How can i disable this?

3

Doesn't look like there's any way to do it in the UI.

But, you can edit the /usr/share/kde4/services/plasma-runner-bookmarks.desktop file.

kdesudo kate /usr/share/kde4/services/plasma-runner-bookmarks.desktop

Find this line:

X-KDE-PluginInfo-EnabledByDefault=true

and change it to:

X-KDE-PluginInfo-EnabledByDefault=false

You'll have to restart plasma for it to take effect:

kquitapp plasma-desktop
plasma-desktop

I'm not sure if this change will persist when KDE is updated, though. My recommendation would be to instead avoid all this trouble by just using the lancelot application launcher (package name is plasma-widget-lancelot). I prefer it to kickoff, and it has a UI that allows you to disable the bookmarks runner for the search bar.

  • 1
    Thank you! I had the same problem when upgrading from openSUSE 12.2 to openSUSE 13.1 and with your answer as a starting point, I found a solution that satisfies me (see my answer). – Jaan Nov 25 '13 at 10:33
7

For KDE 4:
Copy /usr/share/kde4/services/plasma-runner-bookmarks.desktop
~/.kde/share/kde4/services/plasma-runner-bookmarks.desktop

For KDE 5:
Copy /usr/share/kservices5/plasma-runner-bookmarks.desktop
~/.local/share/kservices5/plasma-runner-bookmarks.desktop

Replace a line X-KDE-PluginInfo-EnabledByDefault=false.

Relogin.


Shorthand for the above:

mkdir -p ~/.local/share/kservices5
sed 's/EnabledByDefault=true/EnabledByDefault=false/' \
    /usr/share/kservices5/plasma-runner-bookmarks.desktop \
    > ~/.local/share/kservices5/plasma-runner-bookmarks.desktop
  • After a reboot it seemed to work. – kas Jul 22 '18 at 19:04
  • FWIW you don't need to logout/login, nor reboot. Restarting plasmashell is sufficient: kbuildsycoca5 && timeout 5 kquitapp5 plasmashell && plasmashell – Sparhawk Jan 27 at 23:05
  • or short cp /usr/share/kservices5/plasma-runner-bookmarks.desktop ~/.local/share/kservices5/plasma-runner-bookmarks.desktop && kate ~/.local/share/kservices5/plasma-runner-bookmarks.desktop and then @Sparhawk's command using Alt + F2 – Joschua Apr 14 at 19:14
5

(Inspired by user2798869's answer.) Another option is to create a file /home/(username)/.kde/share/kde4/services/plasma-runner-bookmarks.desktop with contents

X-KDE-PluginInfo-EnabledByDefault=false

This has the advantage over modifying the file in /usr/share/kde4/ that it will certainly persist software updates, and even OS reinstall if you have a separate home partition.

(I have tested this on openSUSE 13.1, where the file path is /home/(username)/.kde4/share/kde4/services/plasma-runner-bookmarks.desktop, but I guess Ubuntu uses .kde instead of .kde4)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.