First of All I'm using Ubuntu 13.04 and I don't remember this problem has ever been produced by the previous releases.

Unity Global Menu Integration is missing not for all the applications but some of them. Here it is the programs that can't integrate with Unity Global Menu:

  • Software Center
  • Gedit
  • Geany
  • Terminal
  • Archive Manager
  • Brasero
  • Adobe Reader
  • Document Viewer
  • Filezilla
  • ...

Some programs can still integrate their menus with the global menu, such as Firefox and File Manager.

I want The Global Menu Integration back.

Thanks in advance.

  • Gedit, Terminal, Document Viewer and other programs must integrate, whereas Synaptic doesn't. Jul 28 '13 at 16:40
  • Sorry, I misremembered. My question has been edited.
    – Hckr
    Jul 28 '13 at 17:59

Provided that some of the programs you mention must integrate with Unity global menu, I suggest to check that you have the required packages.

I. Open synaptic

II. Search «appmenu» in Quick filter. According to me, these are the packages you must have installed:

enter image description here

  • They are all installed already.
    – Hckr
    Jul 28 '13 at 17:54
  • Then you can try to «reset» unity to default. One way is by means of «ALT+F2 unity». Another way is with the use of Unity Tweak Tools Jul 28 '13 at 18:16
  • I tried ALT+F2 unity, no change.
    – Hckr
    Jul 28 '13 at 18:30
  • In order to see if it is your config, create another user, log in and check if it has the same problem. Jul 28 '13 at 19:04
  • I was going to right this on my question: Guest account has the same problem. By the way, I have just tried Gnome3 PPA.Archive Manager's integration is now fixed.
    – Hckr
    Jul 28 '13 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.