I've successfully installed Adobe Digital Editions using Wine in Linux Mint 10, and it appears that the program operates normally for the most part, as I can open eBooks and view my library. However, in Windows, when I plug in my Nook, the Nook shows up in ADE in my library view. It does not do so in Linux. I can simply copy the files to the Nook, as Linux treats it as a Mass Storage Device, but I download library books, and I think ADE has to do something special with the books for them to be recognized by the Nook as having the correct copyright info. So, I have 2 questions.

1) Is it possible to get the Nook to show up in ADE?

2) If not, is there a sufficient workaround? For instance, get ADE to "authorize" the book, then simply transfer it over to the Nook as Mass Storage Device via command line or drag and drop. Or does ADE even need to do this?

Note: I have used the Configure Wine program to map /media/nook to the D: drive, but it still doesn't work.

4 Answers 4


As soon as ADE downloaded the ebook, it added the encryption keys to it. With that, Calibre can decrypt the epub file and transfer it to your nook.


This post in the Ubuntu Forums describes how to get Adobe Digital Editions to recognize the Nook.

From the post.

  1. Plug in the nook and it should auto-mount to /media/nook.
  2. Open the Wine Configuration tool (Applications->Wine->Configure Wine) and click on the Drives tab.
  3. Find and click on the drive mapping for /media/nook. In my case this was the I: drive.
  4. Click the Show Advanced button and from the Type drop-down, select Floppy disk.
  5. Click Apply and leave the Configuration window open. In my case, whenever I clicked OK or closed the window, it would not save the settings. This could be an issue on my end.
  6. Open Adobe Digital Editions and the nook should appear in the list.

I had tried this before, but I had AutoDetect selected as the type of drive, and not floppy (which is not obvious).

Unfortunately I found this answer 5 minutes after issuing the bounty.


FWIW, I tried this and the NOOK still didn't show up in Digital Editions until I used Configure Wine, added "digitaleditions.exe" and told it to report Windows 7. After I did that and closed and restarted Digital Editions, the NOOK appeared.


Adobe Digital Editions would not recognize my NOOK no matter what I tried. I installed ADE through WineTricks so if I just click MENU > WINE > Configure Wine I got nowhere. I had to go to MENU > WINE > WineTricks > Select ADE > RUN WINECFG. Then under DRIVES tab I created a new drive letter F (it automounted E but would not keep changes) added directory /media/samdrucker/NOOK/ changed to floppy drive and wala, no more beating my head against the wall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.