9

When i try to launch any game in steam it comes up with preparing to launch for e.g Dota 2 then that box closes and never loads game up.

Any help would be appreciated.

1
  • Just restart steam...!! It worked for me...!!
    – SY_13
    Aug 24, 2015 at 14:35

5 Answers 5

3

Try this:

  • Right click on TF2 in your library → Properties → Set Launch Options
  • If you only have optirun, enter: optirun %command%

The above did not work for me and I had to set the launch options as

LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 optirun %command% 
2

This occurred for me after backing up a game. It would show the 'Preparing to launch' dialog box then close it without launching. The solution for me was this:

  1. Make a backup of the game.
  2. 'Delete local content' for the game (in Right-click -> Delete local content)
  3. Restore the game from your previous backup.
2

I got the same problem with other games and could fix it by out commenting the lines

GAME_DEBUGGER="strace -f -o strace.log" LD_PRELOAD=../src/thirdparty/gperftools-2.0/.libs/libtcmalloc_debug.so:$LD_PRELOAD

in the launch script, hope this helps

1
  • 1
    Can u explain what this comment does? I'm just curious...!!
    – SY_13
    Aug 24, 2015 at 14:32
2
  • right click > properties
  • at the bottom > force the use of specific steam compatibility tool

Just try out all the compatibility tools, whichever works for you.

I had the same issue in launching 'War selection'. Selecting 'proton 4.11' helped. Steam was able to launch the game.

1
  • I use Ubuntu 20.04 LTS and this some games worked, but some didn't. I installed proton 5.13 as that is current version and all the games works again. Thanks for this tip!
    – 99problems
    Nov 28, 2020 at 21:13
0

Is your computer x64? For some reason some Steam games need the x86 library... This happened to me as well, and Steam Support told me to do the following:

  1. Open up Terminal

  2. Type the following command:

sudo apt-get install ia32-libs

You might need to put your login password because of the sudo command...

After you've done, it should work with any game. If it doesn't, you might need to enable de Dev. Branch of the game. So, to do so:

  1. Right click the game you want to play, and chose properties.

  2. Click in the Betas tab, and select Development Branch from the dropdown and then close the window.

  3. Try to open your game.

If this doesn't help, you might want to contact Steam Support. Gaming in Linux is in some point "new" and still has it's "problems" so they should help you though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.