16

Some file is in my NTFS file system which I can't delete. It's giving this error:

rm: cannot remove `zigBqC04': Input/output error

Any other files also could not be copied in that folder and showing error message as:

Error opening file 'file-path': Input/output error

Any solution.

8

Looks like the filesystem has some errors on it. Do full scandisk /checkdisk from windows. (scan disk for errors)

  • That's probably the best one can do without damaging the proprietary filesystem or replacing the filesystem. – LiveWireBT Jul 28 '13 at 10:30
  • 1
    @staticd As of 2019, is this still the best solution? I'm using the latest version of KDE, and am more interested in a *buntu specific solution. – Sarah Szabo Jan 4 at 7:58
4

The same circumstance I met. I am pretty sure I am going to delete the directory. So I try to use rm -rf XXX and also Shift + Delete to remove but both failed because of the same error. Interestingly, I fixed it by right clicking the directory Move to Trash and then Empty Trash. Hope works for you too.

1

may need to be logged in a root to do this. If so, type:

sudo su

in to Terminal and navigate with terminal to where zigBqC04 is and rm <filename> to remove files or rmdir <dir> to delete folders replace <---> with the file or folder name. Wild cards ( & ?) can be used.*

  • I also tried as a root but still can't. – Prakhar Jul 27 '13 at 17:20
0

If it is an NTFS or FAT file system and you don't have access to Windows just copy the files that you want to keep from the USB drive onto your hard drive. Then format the USB drive again using GPARTED or similar partition manager to NTFS or FAT. Followed by copying all the files back onto the USB drive. Worked for me.

0

A workaround that thankfully worked for me was to plug the drive into a Windows system and delete the offending files and folders using Shift + Delete (immediate delete without Recycle Bin).

After that, the issue seemed to be resolved when the drive was returned to Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.