I have a steno machine that I'm trying to connect to my computer with free steno software I downloaded called Plover...

It's connected through a serial cable and usb-to-serial converter, and my computer knows it's there but for some reason the software isn't connecting to it?? And I'm so confused. I'm trying to connect it to the right port (/dev/ttyUSB0) so I'm really not sure what the problem is.

[ 6737.415564] usb 2-1.2: new full-speed USB device number 4 using ehci_hcd
[ 6737.501784] usb 2-1.2: New USB device found, idVendor=067b, idProduct=2303
[ 6737.501806] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 6737.501823] usb 2-1.2: Product: USB-Serial Controller D
[ 6737.501836] usb 2-1.2: Manufacturer: Prolific Technology Inc. 
[ 6737.502470] pl2303 2-1.2:1.0: pl2303 converter detected
[ 6737.504642] usb 2-1.2: pl2303 converter now attached to ttyUSB0

Is it maybe a permissions problem?

(precise)root@localhost:/proc/tty/driver# ls -l
total 0
-r--r--r-- 1 root root 0 Jul 26 09:00 usbserial
: cd /dev
: /dev$ ls -l
crw-rw---- 1 root   402 188,   0 Jul 26 08:55 ttyUSB0

Don't know.

I also get this when I run the program from terminal:

Xlib.xauth: warning, no xauthority details available

Does that mean anything?

  • Someone please have an answer for me! – Kristen Jul 26 '13 at 20:13

You were correct when you thought it was a permissions problem.

Either use 'sudo' to run the software that's supposed to talk with the device, or run the following command:

sudo chmod 0666 /dev/ttyUSB

when the device is plugged in. The above command will force the permissions on the device to allow read/write everyone.

The problem is that you'll have to run the above command EVERY TIME you unplug and reconnect the device.

  • Generally is not a good idea to run software with elevated privileges, nor giving read and write rights to everyone. Why you believe is a permission problem? Any reference? – Pablo Bianchi Mar 6 '20 at 5:08
  • @PabloBianchi I was experimenting heavily with a USB device some time ago and ran into the exact problem. Despite everything I tried, I could not read the device at all, unless I ran as root, or set the permissions as described. The alternatives which I only learned about long after this answer was forgotten are to hope that the group is something you can add your account to, or craft a 'udev' configuration file that recognizes the device and sets it so that you can read/write as a normal user. – EdwinW May 23 '20 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.