3

i've got Ubuntu Precise ( 12.04.2 ) running via VirtualBox on Windows 7 host machine ( both 64 bit systems ) - intel i3 2350m with 4GB of RAM - 1.5 GB allocated to Virtualbox.

All multimedia played on Ubuntu is very slow and what is most disturbing - audio is played in very weird way - bassy , sound like alien :(

VirtualBox uses WindowsDirectSound ICH AC97 , 32 Megabytes of Video memory ( intel hd3000 )

any ideas how to fix it ?

--edit Install also lubuntu 12.04 , same problem

0

Appears to be a common problem for many Linux guests, regardless of host operating system.

A workaround/fix was identified by someone using Ubuntu 9.04 was to stick the following into /etc/modprobe.d/sound.conf (might need a .conf extension, or might not):

options snd-intel8x0 ac97_clock=48000
options snd slots=snd-intel8x0
# CvwD.FAMlirE10w6:82801AA AC'97 Audio Controller
alias snd-card-0 snd-intel8x0

The above worked like a charm (ie: I didn't analyze it very deeply, just "had faith, copy/paste") for me in Ubuntu 13.10.

The key must be setting the clock to 48000, IMHO. I'm not sure about the rest of the stuff having to do with "intel" things. That #-commented line is probably doing nothing, but who am I to question it? Maybe someone else will come along and help clarify these minor concerns.

For reference:

0

Another solution was posted at SuperUser, involving a default-fragments value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.