2

I want to delete a tar.bz2 file from my pendrive. I tried shift+delete, but nothing happened. Then in terminal I tried sudo rm command, I got the following error -

rm: cannot remove `avi.tar.bz2': Read-only file system

I tried sudo chmod 777, but the output is -

chmod: changing permissions of `avi.tar.bz2': Read-only file system

I am not able to remove the tar.bz.2 file. Any help?

  • The filesystem itself is read-only, it can happen for number of reasons. – meskobalazs Jul 26 '13 at 8:35
  • Check if mount -o rw,remount /dev/sdc works. /dev/sdc is example name of your pendrive. – Danatela Jul 26 '13 at 8:36
  • So what can I do now, just have a back up and format the pendrive? – user2315033 Jul 26 '13 at 8:37
1

you need to mount it in read write mode, since chmod is a write operation it will not work.

Check this instructions

Make Read items RW

  • I could delete the tar.bz2 file using mount -o ... command suggseted by Danatela. Thank you soo much – user2315033 Jul 26 '13 at 8:40
  • @avinash, if you want to say something to me, you should answer below my comment and put @ sign before my name. Now RayOfCommand got your message :) – Danatela Jul 26 '13 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.