1

I have Xubuntu 13.04 on an old Dell Inspiron with 1 GB RAM and about 2 GB swap.

Each time I launch an application (e.g. Thunar or Evince) it takes a pretty long time to be launched and I see a lot of disk reads/writes.

If the system was short on memory, this would be understandable as the system would use swap. But that's not the case in my situation (i.e. I have this problem even when the RAM is almost empty).

I had the same problem with this laptop with an older version of Ubuntu as well. Maybe the problem is with the old ATA drive?

  • How much RAM do you have installed? and what size it the swap disk partition? – SimplySimon Jul 26 '13 at 8:17
  • What application gives you this problem? How much time (you mean a few seconds, or a few minutes)? Does this occur every time you open a program, or only once? If you open a terminal, type free and press Enter, what's the output, before and/or after launching the program? – ignis Jul 26 '13 at 9:30
  • I edited my question above to answer your questions. – Reza Jul 26 '13 at 10:39
  • Swap performance is possibly a symptom but not necessarily the cause. Older ATA-Drives may get misconfigured from BIOS. Check the BIOS settings for PIO-Modes or Ultra-ATA-settings. If possible, select the fastest option in BIOS and verify that the kernel picks them up by grepping dmesg for ATA or PIO. – aquaherd Jul 28 '13 at 20:29
0

Most probably the settings of swappiness would be the key. Ubuntu by default is set to swap the system resources before (not after) it will need to swap it. Fortunately, this option, as all things in Linux world, is configurable. Try to disable swap temporarily, to test, if this will help you, by

sudo swapoff -a

and later back on with

sudo swapon -a

If this will be the solution for you, you can play with swappiness settings. This Q/A should be good guide for you (Is it safe to turn swap off permanently? ).

... and yes, problem could be the old ATA drive, respectively the drive controller, as the I/O operations take longer than expected and system is waiting for it. Try to monitor system with top command, if this is the case, there will be lot of CPU waits (values more than 15-20%). You have to test it with app, which is not yet loaded into memory.

If this is the case, then consider to reduce I/O as much as possible. Play with swappiness (for example zero). It would help to add more RAM then, should have to be possible to increase it to at least 2Gigs.

  • Thank you. I switched swap off and it got better. Then I changed swapiness to 30 and turned swap on. Still more disk read/write that my other laptop. – Reza Jul 26 '13 at 10:28
  • Not sure if reboot is necessary. Try set swappiness to 10 as minimum, could be fine then. – Dee Jul 26 '13 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.