2

I get this red sign on top saying that I must update manually due to network problems. When I click on show updates I get the software on this computer is up to date and I click ok, but the red sign will not go away. When I restart the computer it is gone but reappears in a few minutes. How can I remove this red warning?

  • 3
    Include the output of running sudo apt-get update && sudo apt-get upgrade on a terminal. Please edit the question to include this. – edwin Jul 26 '13 at 5:09
0

There are a number of alternative ways you can follow to get rid of the constantly appearing Ubuntu update sign.

Recommended methods

  1. Force all updates to install:

    sudo apt-get dist-upgrade
    

    Notice that this may cause some packages to be uninstalled, due to conflicts. So check what changes will be made to your system. You will be prompted to do this upgrade. Also, when new updates arrive, you will be notified again. This is default method.

  2. Install Unattended upgrades:

    sudo apt-get install unattended-upgrades
    sudo dpkg-reconfigure unattended-upgrades
    

    Say "Yes" in dialog window. For me, it is a best method.

Wrong methods

The next 2 methods I do not recommend and put them only for comparison:

  1. Disable Update notifications:

    • Open Startup Applications:

      Startup Applications

    • Disable Updates notifier there

    Your application lists will still be updated, but you won't be notified.

  2. Disable Updates checking totally

    To stop the pop-up run update-manager

    Then in settings, set Update automatically to 'Never' and Notify of new version to 'Never'

    Sample settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.