1

I installed Ubuntu 13.04. Then I installed too KDE Plasma Environment. Then I removed KDE. Everything went fine. I can now log with Ubuntu (Unity).

Only (small) remaining problem: on the boot page (Grub), the command line does not show "Ubuntu 13.04" but "Kubuntu 13.04". Is there a way to fix this little inconvenience? Thanks in advance.

1

Default value of variable GRUB_DISTRIBUTOR is set to
lsb_release -i -s 2> /dev/null || echo Debian by /etc/default/grub script while generating grub.cfg.

Check your /etc/default/grub.d/ directory for scripts which could overwrite this variable.

In my case it was /etc/default/grub.d/50_kubuntu.cfg which has been created by KDE Plasma Environment so I deleted it and generated grub.cfg again.

To solve this problem, simply type into terminal:

sudo rm /etc/default/grub.d/50_kubuntu.cfg
sudo update-grub
2
  • Nice answer, but could you expand your answer and explain what happens as you do this, it may help people with a similar problem in the future. Jul 29 '13 at 16:27
  • I edited my answer so I hope it will help better understand why it happens..
    – JOndra91
    Jul 30 '13 at 1:12
0

Just run in a terminal the following command:

sudo update-grub

If still the problem persist, run:

sudo sed -i 's/Kubuntu/Ubuntu/g' /boot/grub/grub.cfg

You can also see:

6
  • Thanks for supporting. The first command (sudo update-grub) did not change anything. The second command (sudo sed -i 's/Kubuntu/Ubuntu/g' /boot/grub/grub.cfg) changed the line in the "Grub page" (Ubuntu instead of Kubuntu) but the following page is still displaying "Kubuntu 13.04". After this, I reach normally the login page.
    – SwissEagle
    Jul 25 '13 at 13:50
  • The answer is: Ubuntu GNU/Linux Advanced options for Ubuntu GNU/Linux Memory test (memtest86+) Memory test (memtest86+, serial console 115200) Windows 7 (loader) (on /dev/sda1) Windows 7 (loader) (on /dev/sda2)
    – SwissEagle
    Jul 25 '13 at 14:02
  • @SwissEagle What is the result of grep -E '^menuentry|^submenu' /boot/grub/grub.cfg | cut -d '"' -f2 | cut -d "'" -f2 command? Jul 25 '13 at 14:03
  • The answer to your last question is just above it. Anyway, thanks again for helping. I did it all again. The Grub shows "Ubuntu" but the next page still displays "Kubuntu 13.04" (even if everything is proper "Ubuntu" after this).
    – SwissEagle
    Jul 25 '13 at 14:10
  • @SwissEagle I edited my answer. Jul 25 '13 at 14:23
0

The problem might be the kernel and initrd images (vmlinuz-* , initrd.img-* ). Try reinstalling your kernels and it might fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.