12.04 (32-bit), Unity desktop skips the login screen after resuming from suspend mode. It just starts the session with the user logged in. I have a password set and it shows the login screen on boot or reboot, and it was the same on resume after suspend, but recently it starts skipping the login screen on resuming after suspend. I would like to have the login screen showing up again after suspend. How can I fix this?

Thank you for your time and help!

This is my settings in System Settings -> Brightness and Lock

enter image description here

And in Ubuntu Tweak the Login Settings:

enter image description here

  • @user68186 sorry I should clarify this in the question - I don't get a password prompt in the middle of locked screen when I resume from suspend (actually it is not locked at all when resumed from suspend it just start the previous session). BTW - I've tried clicking on 'Lock Screen' from the gear icon (top right) and nothing seems to happened, although the shortcut Ctrl-Alt-L is working and it locks the screen, and I get the password prompt, is it possible that it doesn't lock the screen when go to suspend mode? – venta7 Jul 24 '13 at 20:16
  • @user68186 "Disable Lock Screen" is not checked. I went through Ubuntu Tweak's settings, didn't notice anything else that should affect this behaviour not to lock the screen on suspend. – venta7 Jul 24 '13 at 20:34
  • @user68186 I found this: bugs.launchpad.net/ubuntu/+source/linux/+bug/1083030 it is an old post and doesn't fix this issue. The strange is that I didn't have this problem few days ago. The only thing I can think of that can have some impact on this is that I've tried Nemo file explorer a while ago with Cinnamon desktop environment installed as well, then I switched back to Nautilus and clean up Nemo and Cinnamon. Thank you for trying to help me and clarifying the problem I'm experiencing. – venta7 Jul 24 '13 at 20:54
  • let us continue this discussion in chat – venta7 Jul 24 '13 at 22:27

You actually just need to have gnome-screensaver installed and running.

I needed to add it to the list of apps to start when signing in.

Require password after suspend is a setting for this piece of software.


It could be worth checking your user account and making sure that the Automatic Log in option is set to Off

enter image description here

As you can see from the image above, I have mine set to ON.

  • @SimplySimon Thanks for the tip (didn't know I have this option there), however it doesn't fix my problem - mine is set to OFF. – venta7 Jul 24 '13 at 19:38
  • @user68186 That is why in the text I said "Automatic Log in option is set to Off" – SimplySimon Jul 24 '13 at 19:42
  • @user68186 I just re-read the question... Sorry, I got it wrong – SimplySimon Jul 25 '13 at 12:20

Found the answer of my troubles: I've had Nemo installed before as an alternative to Nautilus and it requires Cinnamon desktop environment. I didn't like the integration of Nemo with Unity and moved back to Nautilus as a default file explorer. I've used the following commands to remove Nemo:

sudo dpkg -r nemo-fileroller
sudo dpkg -r nemo
sudo add-apt-repository --remove ppa:gwendal-lebihan-dev/cinnamon-stable

Perhaps at that time I forgot to remove Cinnamon also and I had cinnamon-screensaver running along with gnome-screensaver (checked on System Monitor). I found this thread how to remove cinnamon which helped me to remove Cinnamon using:

sudo apt-get --purge autoremove cinnamon 

I didn't understand after that how gnome-screensaver was gone as well, so I've installed it:

sudo apt-get install gnome-screensaver

Now I found this thread also (of which mine is duplicate): why doesn't ubuntu 13.04 prompt me for a password after suspend?

Many thanks to @user68186 who tipped me to look for Lock screen and Password prompt skipped after suspend.

  • Thanks for sharing the solution. Please accept it as the correct one. This is a problem that occurred under very specific conditions that may not be useful for most people. – user68186 Jul 25 '13 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.